Announcement: HADashboard v1.72

@aimc - Any ideas about my issue?

Hi Rob - sorry I missed this. I don’t really have anything to add as I am not using the IFrame widget, and nothing in any of my updates should have made any difference to it.

No problem - thanks. I just don’t understand what happened as I didn’t change anything on my end during the updates but maybe I’ll just delete it and start from scratch again. Cheers.

1 Like

Looks looks a config issue - HAPush sees the events but does not act on them, my guess would be because the widget names in the dashboard don’t match the entity ids you have for the various devices - can you check that, and maybe post a sample of your dashboard code?

1 Like

ill try to implement your iframe tonight and see what could be the problem.

1 Like

Here you go:



  • <li data-row="2" data-col="1" data-sizex="1" data-sizey="1">
      <div data-id="Living_Room_Lights" data-title="Living Room Lights" data-view="Hadimmer"></div>
    <li data-row="2" data-col="2" data-sizex="1" data-sizey="1">
      <div data-id="Bedroom_Lights" data-title="Bedroom Lights" data-view="Hadimmer"></div>
    <li data-row="1" data-col="3" data-sizex="1" data-sizey="1">
      <div data-id="Game_in_PS3" data-title="Game in PS3" data-view="Hascene" data-bgcolor="#003300"></div>
    <li data-row="1" data-col="4" data-sizex="1" data-sizey="1">
      <div data-id="Movie_Time" data-title="Movie Time" data-view="Hascene" data-bgcolor="#003300"></div>
    <li data-row="2" data-col="3" data-sizex="1" data-sizey="1">
      <div data-id="Main_PC" data-title="PC" data-view="Hascene" data-bgcolor="#003300"></div>
    <li data-row="2" data-col="4" data-sizex="1" data-sizey="1">
      <div data-id="Relax" data-title="Relax" data-view="Hascene" data-bgcolor="#003300"></div>
    <li data-row="3" data-col="3" data-sizex="2" data-sizey="1">
      <div data-id="Watch_Sat_TV" data-title="Watch TV over Satellite" data-view="Hascene" data-bgcolor="#003300"></div>

Home Assistant - light.yaml:

[code] - platform: insteondimmeroh
name: “Living Room Lights”
resource: http://localhost:8080/rest/items/ldLRLamps

insteondimmeroh comes from here:

Once again, Home Assistant is able to respond to button presses. Here’s the output from Dashing. I turn off the “Living Room Lights” and turned it back on. - - [29/Dec/2016 11:42:19] "POST /homeassistant/dimmer HTTP/1.1" 200 11 0.0961 - - [29/Dec/2016 11:42:24] "POST /homeassistant/dimmer HTTP/1.1" 200 11 0.0914

what is the configfile from hapush?

to me it seems that hapush isnt pushing, so maybe is the given url wrong?

I will post it again from one of my previous posts.

Both Home Assistant, HADashboard, and HAPush are in the same machine.

and suddenly it hits me.


probably is wrong and should be


hass doesnt have capitals in the entity IDs.


HASS seems to be case-insensitive and HAPush does not acknowledge that and you know what? You are right! After I modify the .erb file, it worked!!! Shouldn’t that be documented in HADashboard/HAPush or am I missing something in documentation?

Update after a while: Maybe HADashboard and HAPush needs to convert upper/lower case entity_id variables to lowercase using an entity_id.lower() function where “entity_id” is a string variable…If I have left the data-id"" entity ID variables before, Home Assistant responds just fine. Maybe have something like this in an “if” statement such as:

[code]if((“Living_Room_Lights”).lower() == (“living_room_lights”).lower())

Then respond to event


I might look into the code although I have never done any programming with Python.

Update 2: The code does have syntax error, so I’m going to go through a Python tutorial to learn Python. It’s only a pseudo code.

it is strange that hass responses anyway.
within hass there are several places where i have struggled with capitals in the beginning. since then i only use capitals in friendly names.

because you are expected to use entity IDs exactly like in hass and because hass doesnt have capitals in its entity IDs there is no need to check for capitals in the Dashboard and Hapush.

HASS did not expect me to use lowercase letters for entity IDs. If it does, it should have said say in the log file.

robert i created a new erb file with this code:

<div class="gridster">
    <li data-row="1" data-col="1" data-sizex="5" data-sizey="4">
     <div data-id="iframeId1" data-view="Iframe" data-src=""></div>

and it displayed this:

when i started the try out i made an error in the file outside the widget and got a simular view you showed.
so maybe the problem is in another part from the file then the part you posted.

please try the code i gave as a new erb file to see if that functions correct for you.

1 Like

you can check out your entity IDs in Hass.
just go to developerstools in your frontend and chose the second 1. (states)
you will see all your entities and you will see that all your entities are in lower case.

you gave it a neme with upper cases, but the entity ID is in lower case only. ALL entity IDs are.
if you are creating automations in hass and you use upper cases in entity IDs you will also get into trouble.

Okay, great. I’m in trouble because I did not HASS is case-sensitive for entity IDs. Will make sure to use lowercase in entity IDs in YAML files. HASS did not tell me that entity IDs need to be in lower-case. Not even in home-assistant.log.

Perhaps the next version of HASS will tell me that light.Living_Room_Lights is invalid. I tried changing to this:

- name: Movie Time entities: light.LIVING_ROOM_LIGHTS: state: "on" brightness: 1 light.Bedroom_Lights: state: "off" media_player.living_room_receiver: source: "Android TV"

And it works. No error in home-assistant.log.

i didnt know it for a long time to.
in many cases hass just translates all upper cases in names automaticly to lower cases.
thats also the case in your case.

but if you make an automation you need to call them exactly like hass hass created them, so in lower cases

i see your example now and thats still 1 of the things i see in hass. it isnt Always consistant.

i created this light this weekend:

  platform: limitlessled
    - host:
      - number: 1
        name: Vitrine in de gang

and now the name from the entity is light.vitrine_in_de_gang

in some automations i can use light.Vitrine_in_de_gang but in templates i really need it without the upper case.
if i use appdaemon it will tell me that light.Vitrine_in_de_gang doesnt exist in hass.

so i prefer to stay away from upper cases completely

Well that makes sense. I will make sure to keep it consistent.


1 Like

Thanks man - I’ll try this out sometime later in the evening and report back.

I appreciate it and you’re probably right about some stub of bad code stuck in there.

I know this is a couple weeks old, but did you ever figure this out? I’m having a similar issue on my end as well.

Have had so much going on that I haven’t really had a chance to look at it yet.

But when I do I will update here.