Another Homeseer migration help request - ZWave

I have finallly given up on my 8 year old HS3 installation, it has worked well but its getting left behind, and I detest HS4.

I’m stuck on Zwave migration, and after hours of serching can only find half answers, so what I would like to know is where I find the keys for ZWave security in my HS3 install.

I’ve looked in the zwave ini file and can find one obvious key, I’ve tried adding a leading 0 to any single digit entries and then removing hyphens and using that as my S0 legacy key, but not sure if that is correct or not.

But what about all of the other S2 keys? I’ve generated keys within HA and all seems OK, however after 30 minutes every single one of my devices is unknown prooduct and unknown manufacture. If I ping a mains powered device I get power info back but nothing else. ANy help great appreciated.

Unknown manufacturer 0x001e 0x0005 Unknown product 0x0002

When I converted, I removed my devices from HS3 then added them to HA. PIA but I only had to do it once. I had 87 Z-wave devices and it took me about a day.

1 Like

Which I would do but I’m 50 miles away doing at as a proof of concept before making the switch. So as well as not being practical, doing it that way means that it’s a destructive test and no step back :slight_smile: and I’d like to understand it anyway.

I did it when HS4 had just come out. I won’t bad mouth any product, but the reason I changed was I felt HA was a superior product, and it only has gotten better. I use Nabu Casu to access while I am away from home and as a way to give back to the developers. It is low cost and it just works. I also have a Ubiquity infrastructure which folds nicely into HA. There is nothing that I have wanted to do that I could not get accomplished. I hope someone more knowledgeable with z-wave can give you advice.

1 Like

If you can use the new Zwave plus plugin in HS3, that would be the way to convert. Not sure if it works with 3 or if it requires HS4 though.
Something to look into I guess.

1 Like

The HomeSeer S2 key is encrypted so you need to ask in that forum. I know they provided a way to export it in HS4, but I don’t know about HS3.

You didn’t provide some important details - How many nodes in your network are S2 encrypted? S0? Unencrypted? If you don’t know those details, you probably aren’t ready to migrate.

I now know what the issue is, the devices are working fine but ithin my docker container all of the config files are missing, and no idea how to add them.

Just installed this as a container in docker running on a synology NAS. ALl configured and working and connected to Home Assistant, however ALL of my devices are unknown, looking at the zwave log file it is unable to load any of the log files with errors like below, in the store the config directory is empty, is it a fault with my setup, the version I’ve installed or have I missed something and need to add these files?

2024-05-03T15:16:45.807Z DRIVER starting driver…
2024-05-03T15:16:45.807Z DRIVER opening serial port tcp://
2024-05-03T15:16:45.820Z DRIVER serial port opened
2024-05-03T15:16:45.822Z SERIAL » 0x15 (1 bytes)
2024-05-03T15:16:46.828Z DRIVER loading configuration…
2024-05-03T15:16:46.843Z CONFIG Using external configuration dir /usr/src/app/store/.config-db
2024-05-03T15:16:46.844Z CONFIG version 12.5.6
2024-05-03T15:16:46.846Z CONFIG Could not load scales config: The device classes config file does not exist! (

I’ve fixed it, I had to use the synology terminal to /bin/sh into the container, then force delete the /usr/src/app/store/.config-db directory, (it only had one file in) then recreate it and reboot and immediately on startup all of the files populated and my devices started to be recognised.