Another Smartthings Integration Issue - ERROR: Something went wrong. Please try to install the SmartApp again

Hi All,

Quite new to the home assistant scene and just trying to use the smartthings integration however i keep running into an error when it tries to authorize it.

Error i can see in the logs section is:

2020-10-20 21:23:15 ERROR (MainThread) [homeassistant.components.webhook] Error processing webhook 657ef8a5dbf54aa2a29af115b99b8de3f2ee7cc826ba91a6d0b1cd875825bb2b
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/components/webhook/”, line 96, in async_handle_webhook
response = await webhook[“handler”](hass, webhook_id, request)
File “/usr/src/homeassistant/homeassistant/components/smartthings/”, line 508, in smartapp_webhook
result = await manager.handle_request(data, request.headers)
File “/usr/local/lib/python3.8/site-packages/pysmartapp/”, line 174, in handle_request
resp = await req.process(smartapp, headers, validate_signature)
File “/usr/local/lib/python3.8/site-packages/pysmartapp/”, line 70, in process
raise SignatureVerificationError

Have already setup the duckdns with letsencrypt certs- all working fine, tested on ssllabs and there are no issues with that. I can access the HA remotely with no issues.

I’ve tried:

  • Deleted all old tokens and generated new ones.
  • Get past the section to enter the tokens, it sees my location and when i hit submit i get:
    ERROR: Something went wrong. Please try to install the SmartApp again.
  • Have taken a look at some of the other threads mentioning to delete the end of the url but mine already just ends in clientOS%3Dweb

N.B - If i try the 30 day trial of nabu casa that works fine. I’m not to sure what is causing the issue, or am i missing a step somewhere. I followed the guide: and made sure the external url is https.

Information on the setup.
Running on VM esxi with a static ip set. Port forwards all done from 443 external to 8123 internal port

System Health

arch x86_64
chassis vm
dev false
docker true
docker_version 19.03.11
hassio true
host_os HassOS 4.14
installation_type Home Assistant OS
os_name Linux
os_version 5.4.69
python_version 3.8.5
supervisor 247
timezone Australia/Sydney
version 0.116.4
virtualenv false


1 Like

I’m having the exact same issue. Did you find a resolution?

Same issue here. Anyone found a fix?

EDIT: Nevermind. I gave it another go and then it worked.

Same issue here, cant figure it out, tried, retried…
I have both external_url and internal_url set. I am proxying external 443 -> HA.
Attempting to access the https://<externalURL>/api/webhook/<random string it gives you> presents a “405: Method Not Allowed” which is what I would expect.
Works fine with nabu…

All - I take it you know that the SmartThings platform is transitioning and current methods of interfacing with it will be changing. I don’t know what plans HA has to support the new schema, but in a nutshell there will be two options: 1) implement your code on a cloud server (your own-exposed to the internet, or AWS lambda), or 2) as what they call a ‘direct-connected’ device, which can run on your local LAN.

I’ve devised a way to use SmartThing’s new platform API for direct-connected devices to be implemented on a Pi, which I suspect would be the preferred method for those that don’t want to get into AWS or managing a internet server. If you want to start looking at transitioning your IOT apps to this new world, I’d be happy to help. See my other posts on this topic.

I found in the logs that the nabu URL was still being used to integrate with smartthings, which was failing because I disabled that service. I ended up deleing the server (VMware VM) and rebuilding from scratch.

Just in case anyone else has this problem:

See troubleshooting at the bottom.
(everything passed for me, but the logs proved that there was still some phantom configs left from Nabu)

FYI just in case anyone is wondering how I have it setup:
I have set my external_url and internal_url in my config to be my personal hosted / public domain.
That URL resolves internally to the internal IP, and externally to CloudFlare.

Cloudflare (proxied) --> Server Hosted on DigitalOcean --> Nginx on DO server (proxyPass to ZT ip on HA)(followed walkthrough on these forums) --> ZeroTier tunnel --> (zeroTier IP) NGINX Home Assistant SSL proxy (with letsEncrypt) (443)(no cloudflare flag needed)

Smartthings works now. If you enabled Nabu like me just to check it out, then disabled it, you might have to nuke the entire thing and start over. Just don’t enable Nabu.

I used Digital Ocean, but you could very well use a free tier AWS Linux box.

I’m glad you posted this. My experience matches yours. I had just signed up for HA Cloud and then changed my mind. I signed off HA Cloud and put in my external URL in the general configuration. Then I tried again and got the “something went wrong” error. I checked the log as you did, and saw that it was trying to connect with the nabu URL. Fortunately I had a snapshot from the night before that was current enough for me. I restored and then I was able to complete the SmartThings integration setup.

i have the same problem but a year passed and i put very much work in Home Assistant. so i dont want to start from the beginning and install everything again. is there a way to get rid of the nabu casa config?

Hello. I had the same issue and after struggling for days, I wrote to NABU casa support and surprisingly they gave me an answer that fixed the problem. Long story short

  • Remove Smartthings integration from Configuration > Integrations (obviously !)
  • Delete all files inside the hidden .cloud directory within your main config directory.
  • Delete the “smartthings” file within the hidden .storage directory.
  • Restart Home Assistant
  • Create a new smartthings token and add the integration again

Below the answer from NABU support

Hi Geraldo Maciel Fonseca,
There is no need to delete the Nabu Casa account and this can cause issues with billing later.

There are several parts to remove if you are “resetting” SmartThings and starting with a new account. There’s the integration itself to remove from Configuration > Integrations. Then there’s the hidden .cloud directory within your main config directory. There’s also a “smartthings” file within the hidden .storage directory. And there is your token at SmartThings website. Nothing is actually stored on this end.


need some help please
followed all steps
and I can see my devices (several ac) BUT there are all unavailable
just to explain my special situation: I don’t have any ST hub (it was burned…)
but I have an ac_ip which identify all my Samsung ac at home and they are connected to the ST app and I can use them over there
BUT as I said on the HA they seem unavailable
any advice?

SMARTTHINGS is driving me mad I just can’t get it to work.
I keep getting the error listed below when I try to add smart things to Home Assistant 2021.12.10]( says ERROR: Something went wrong. Please try to install the SmartApp again.

I’m not using so this is my setup.

I have the following add ons installed to access my HA installation remotely:Dnsmask, duckdns, letsencrypt

I’m able to access my HA installation via the duckdns url which means that everything is working a it should from that perspective.

I’ve setup my external url and internal url

The port forwarding is also setup on my router and the certs are also working.

ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

I’ve tried the following.

  • Delete the smart things file in the /config/.storage and / directories, restarted HA and then tried again. I constantly get the strongman…… error
  • Opened the smartthings URL in an incognito window in chrome and safari on my MacBook, iPad and mobile phone
  • Generated multiple smart things tokens and tried multiple times with no success
  • After the failure I can see a smart things file which has the following info in it.

any news how to integrate?

That fixed the problem. Thank you very much for sharing.

thx, that solves my problem, too!

Same here… Had been fighting this for 20 minutes… Really should be placed in the troubleshooting section of deployment guide.

Were you able to resolve this?