Antifurto365 Ialarm

I saw that homeassistant has integration for ialarm. I tried to use it, but I can only activate the alarm, then I can no longer turn it off. I thank those who can help me.

According to the docs this platform supports the following services:

alarm_control_panel.alarm_disarm   <--------------------

Rarely I can turn off the alarm, but then I can no longer turn it on and the status becomes “unavailable”

Sounds like you have connection issues. What do your logs say?

thank you for your help

That’s your logbook, not your system log. Click this:

Open your Home Assistant instance and show your Home Assistant logs.

Logger: homeassistant.components.ialarm
Source: components/ialarm/
Integration: Antifurto365 iAlarm (documentation, issues)
First occurred: 20 giugno 2021, 18:15:55 (242 occurrences)
Last logged: 10:39:03

Unexpected error fetching ialarm data: ‘NoneType’ object has no attribute ‘get’
Traceback (most recent call last):
File “/usr/local/lib/python3.8/site-packages/pyialarm/”, line 229, in _clean_response_dict
i = int(i)
ValueError: invalid literal for int() with base 10: ‘Total’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 180, in _async_refresh = await self._async_update_data()
File “/usr/src/homeassistant/homeassistant/components/ialarm/”, line 83, in _async_update_data
await self.hass.async_add_executor_job(self._update_data)
File “/usr/local/lib/python3.8/concurrent/futures/”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/src/homeassistant/homeassistant/components/ialarm/”, line 74, in _update_data
status = self.ialarm.get_status()
File “/usr/local/lib/python3.8/site-packages/pyialarm/”, line 125, in get_status
zone_status = self._send_request_list(’/Root/Host/GetByWay’, command)
File “/usr/local/lib/python3.8/site-packages/pyialarm/”, line 67, in _send_request_list
total = self._clean_response_dict(response, ‘%s/Total’ % xpath)
File “/usr/local/lib/python3.8/site-packages/pyialarm/”, line 232, in _clean_response_dict
response = response.get(i)
AttributeError: ‘NoneType’ object has no attribute ‘get’

Looks like your alarm is sending a string (word) when the integration expects a number.

You should open a new issue here, including as much detail as you can. Like what faulty behaviour you are noticing, the error log, and model of your alarm.

I asked github for help. However, I have found that the integration works if I do a server restart after each operation

Include that information as well.

Thank you for the help received. After updating home assistant the problem is solved. Greetings