Any owners of Q Cells Q.Volt Hybrid Inverters?

For those who don’t know, I am the creator of the SolaX Modbus Integration on GitHub for Home Assistant Thread on this forum (Not to be confused with the Cloud Based Integration)

I believe these Q Cells Inverters are simply rebranded SolaX Hybrid Inverters.
I would like to investigate and hopefully add support to my Integration.

I need someone willing to troubleshoot and add a USB - RS485 adaptor or an ethernet - RS485 adaptor, if your Inverter doesn’t have built in Ethernet.
This won’t be compatible with the normal PocketLan / PocketWiFi or whatever the Q Cells equivalent is called.

If someone does own an Q Cells Hybrid Inverter do they share one of the Known Serial Numbers with SolaX or do they start in a different manner?


Just wanted to chime in.
As we confirmed yesterday, the Q.VOLT HYB-G3-3P inverter is in fact an SolaX hybrid G4 as it begins it serial with H34.
As we confirmed using modprobe yesterday it also shows its serial and battery level on the expected refference.

I will get back to you once i have placed an HA on this site and tried the integration in a few days.

Thanks for update. Once you have confirmed the full Integration is compatible I’ll update the branding on the SolaX Integration to include Q Cells so owners of the Q Volt Hybrid can easily find the Integration, as it will then become a sub brand.

I have a Q HOME ESS G3 HYB-G2 inverter (that’s what’s printed on the front) and a battery.
my system is Q Cells panels on the roof, Q Cells inverter, Q Cells battery, sold to me as a package.
I would like to help setup/test an intergration but so far have been unable to get home assistant to read any data for the inverter.
FYI: there is a SwitchDin droplet (Raspberry Pi with VPP software loaded) installed between inverter and LAN most of the time but I have also tried testing while bypassing the Switchdin.

Is it connected to the LAN using an ethernet port built into the Inverter or through a USB dongle?

Can you provide a picture of the Inverter? Ideally of all the ports as well.
Does your Serial number start with any of the known serials I linked to on the second post.

There is the possibility that the HYB-G2 is a different Inverter altogether that’s been rebranded?

Connection is via built in ethernet.
Not sure where to find serial number, but this is the first 4 numbers printed on the sticker on the side of the inverter (pic attached) also a pic of the inverter.

Edit: adding pics to show ports on inverter and details/model of inverter and battery.

FYI: I am in Australia if that makes any difference.

It’s hard to tell, it’s potentially a different brand altogether.

Have you tried any of the Solar Modbus integrations yet?

The Q CELLS Q.HOME+ ESS HYB-G1 is rebranded SolaX A1-Hybrid (USA Split-phase version) which would potentially work with the Integration, although I would need to be provided the first 4 digits of the Serial Number to support it.

Q CELLS Q.HOME+ ESS HYB-G2 can’t really make out what it is based on. You would assume it’s SolaX based if the one before and after is?

My unit is 3 phase.
No I have not tried any Solar Modbus integrations yet, do you suggest any to try?
Where is the serial number located on your SolaX unit, I am still unable to find mine.

You could start with mine as the other Q Cells are SolaX ones.

On my Gen3 Hybrid it’s on the right hand side.
If you look at the link a couple of posts up to Known Serial Numbers you will see the list at the moment. Maybe you can match something up?

Had another confirmation that the Qcells Q.VOLT HYB-G3-3P Inverter works fine (SolaX Gen4)

I’ve tried every modbus inverter intergration I could find … some installed, some did not, but none of them gave any sensor info back in home assistant (logs confirmed inverter not reachable via modbus port) which is 1502 for this inverter.

I have confirmed the first 4 digits of the serial number are “1211” does not match any numbers on the list.

I just found out entering the IP address in a web browser returns realtime data (see picture below) is this something your inverter does?

Only the SolaX Gen2 does. Not sure what it actually looks like as I don’t own one.

Are you sure it should be port 1502? As the default is 502

The Gen2 might only have a website when connecting via WiFi. Not sure as like I say I don’t own one.

Hi all,
I’m new to Home Assistant. I do not have any experiance with programming.
But what I read from all datasheets is, that modebus is available on ethernet only.
I have a Q-Cell HYB G3 Inverter and found this on github, working with Wifi and REST-API.

I’m not familar how to integratethis into Homeassist.
Der Det

If you want full control of your Qcells Q.VOLT HYB-G3-3P you either need an RS485 - USB adaptor or a device like the Waveshare

Edit: Just checked the built in SolaX should support the Pocket WiFi connected to your Inverter

I tried both ports 1502 and 502 niether work.

are there any ways to scrape data from the web interface?

You could look into Scrape - Home Assistant or RESTful - Home Assistant but I can’t offer any support for either.

You can use the REST API Form the Website. This works, but refresh rate is 5 mintutes.

Token must be generated in your portal (API -Key) Serial is your serial from the wifi Stick.

There is an Rest-API on the Inverters IP as well with POST
curl -X POST --data ‘optType=ReadRealTimeData&pwd=XXXXXXXXXX’

Change the IP to your inverters IP in your private WiFi (not
XXXXXXXXXX is the serial from your Pocketwifi