Any Support for Midea A/C?

Hi all,
I’m a new user, and sorry if I have a bad use of this forum.
I try using midea-discover and get and error when trying to connect to my Qlima SC5225 A/C :

INFO:msmart.lan:Couldn’t connect with Device 192.168.0.6xx:6444
INFO:msmart.cli:*** Found a unsupported ‘0xac’ at 192.168.0.xx - id: 1869169776xxxx - sn: P0000000Q1847C9B6A3833xxxx - ssid: net_ac_38xx

Any Idea ?
Many thanks

Hi,
I also have a Qlima SC5225 and midea-discover is unable to connect to the device. I got:

INFO:msmart.lan:Couldn’t connect with Device 192.168.0.6xx:6444
INFO:msmart.cli:*** Found a unsupported ‘0xac’ at 192.168.0.xx - id: 1869169776xxxx - sn: P0000000Q1847C9B6A3833xxxx - ssid: net_ac_38xx

Is it the same issue for you ?

just mean unsupported now

This looks very promising. Where can we find the rs-485 interface on the ac? Is de usb port where we put the wifi interface in already connected to it?

same issue indeed. just have some patience, it looks they are solving it in the near future

Yes, those Kaisai units are working with Midea Air without any additional configuration.

So your best chance is to mess around with Mac’s code or help him to support your device

In my case, the protocol is quite different from the ground up that the unit doesn’t even work with midea air (despite being midea branded and wifi/cloud controlled using the old apps)

i created a telegram group https://t.me/joinchat/BhU6LRytPXLsiqTIar0jqg
So that everyone can communicate better :joy:

2 Likes

Which app do you use? Nethome or Nethome Plus?
Need you to downgrade app’s version as much as possible.
if the app can run with your AC, tell me the version.

NetHome Plus (is default application for Kaisai) version 3.12.527.
Midea Air 5.0.2.628

The devices with the WiFi interface belong to residential line up. I’m not sure if they have the central control bus.

Check the PCB of the unit for a connector labeled “X Y E”. That’s the RS-485 bus for the central indoor control. There might another connector close by labeled “P Q E” or only “P Q”. That’s a RS-486 bus for connecting to the outdoor units.
It might be that only the multi split VRF indoor units have this.

Regards,
XYE

Hello, everyone, News about the new protocol:
Currently I don’t think I can get k1 key from local. I found that the data sent by the Midea APP is also “ERROR”. I also tried to send some messages to the device, and I still get “ERROR”. So, I suspend development. Hope others can.

Just to clarify, you suspend development on the new protocol or on your component and library in general?

yes.
The more difficult thing is that I don’t have a device running the new protocol.
This brought me difficulties when I needed to debug and capture packets in the LAN.
Although some friends in the group have related equipment, our time zone is different :joy:

But I will also update the old protocol.
For example, get the port and id of the device from the udp response of the device.

1 Like

@mac_zhou, well done on the great work supporting Midea AC!! Appreciate it!
I’ve been using Midea Air and NetHome Plus for a while now, the App itself is reliable but when integrated into HA was a nightmare, when I had a disconnect will have to restart HA to get the AC back to work.

Am using your integration in the past couple days and it is working fine, will report back if I have any issues. I have 5 Springer/Midea units, all of them with the K42MBWF wifi dongle. All of them same model, internal units are 42MBCA09M5 and external units model 38MBCA09M5.

I’m not an expert into the process of getting those integrations as native componentes instead of custom, but what is your willingness to add it as a native component and maybe with a configuration from the integrations interface in HA? I think that will help a lot with those not used with hands on in CLI, etc. Maybe using midea-discover to automatically find the AC on the network and populate HA, will help. What you think?

Hope you got enough coffee!! Appreciate your support!

Hello, I’ve a Maxa Pluma FDL 26R which I can control using Midea App or Nethome Plus, but it seems unsupported when I run midea-discover.
What can I do to help to support this model?

Thanks. Hope it helped you

Hello, i tried the file from @andersonshatch on my carrier crystal II ac unit (midea rebrand) and it’s working. I can change through various functions. Only issue is that off is not working.
Also a proposal: is it possible to extract outdoor and indoor temperature and have them as sensors? That would be awesome since we could have outdoor/indoor temperature through grafana.
Thanks

Sorry, no idea about the mode issue, I never really got my head around the commands the library uses to communicate and after adding the fan_only workaround, I’ve not been able to dedicate any time to it, nor do I plan to.

For temp sensors, no plans to add as individual entities. It’s real easy to add with a template sensor though:

sensor:
  - platform: template
    sensors:
      ac_outdoor_temp:
        value_template: "{{states.climate.living_room_air_conditioner.attributes.outdoor_temperature}}"
        unit_of_measurement: "°C"
      ac_indoor_temp:
        value_template: "{{states.climate.living_room_air_conditioner.attributes.temperature}}"
        unit_of_measurement: "°C"

Remember to use the right entity_id if it’s not living_room :slight_smile:

2 Likes