Any Support for Midea A/C?

According to the docs, one should better use state_attr, because it doesn’t give an error, if not available. Sorry @andersonshatch, not meant disrespectful! :wink:

Avoid using states.sensor.temperature.state , instead use states('sensor.temperature') . It is strongly advised to use the states() , is_state() , state_attr() and is_state_attr() as much as possible, to avoid errors and error message when the entity isn’t ready yet (e.g., during Home Assistant startup).

That gives us:

# instead of 
states.climate.living_room_air_conditioner.attributes.outdoor_temperature
#use
state_attr('climate.living_room_air_conditioner', 'outdoor_temperature')
1 Like

When I setup the AC it seems like I get the below state. It seems to be connected but there’s 2 notable issues:

  • the live values are inaccurate
  • current_temperature seems to be in celsius rather than Fahrenheit.

Anyone know the issue I may be having? Thanks!

hvac_modes:
  - auto
  - cool
  - dry
  - heat
  - fan_only
  - 'off'
min_temp: 63
max_temp: 86
target_temp_step: 1
fan_modes:
  - Auto
  - High
  - Medium
  - Low
  - Silent
preset_modes:
  - none
  - eco
  - boost
swing_modes:
  - 'Off'
  - Vertical
  - Horizontal
  - Both
current_temperature: 32
temperature: 63
fan_mode: Auto
preset_mode: none
swing_mode: 'Off'
outdoor_temperature: 0
friendly_name: Living Room AC
supported_features: 57
1 Like

Cloud integration: If I don’t use (change anything) in AC for some time (hour?), the first command always reports failure. Also temperatures are update only when command is send to the cloud and HA never update’s its state if AC was for example turned off using remote controller or mobile application.
Is there any way to do something with it, maybe some form of active loop can be configured?

@mac_zhou I’ve got your code installed but it’s not properly connecting to my device, I’ve gone through the instructions 3 times just to be sure I didn’t do anything wrong. I have confirmed I have the correct IP address and double checked the ID from the QR code as well. I don’t know what I could be missing…
It shows the correct target temperature that I have set on the unit but inside HA none of my call service commands make any changes to the device, also it reports the indoor temperature as 32 when it’s really more like 69 or 70:

image

1 Like

Looks like Celcius, not Fahrenheit.

@paddy0174 You mentioed you use a Olimpia Splendid, may I ask which type?
I’m tryin to add a Nexya S4E, but no luck so far…

Found a unsupported ‘0xac’ at 192.168.10.10 - id: xxxxxxxxx - sn: P0000000xxxxxxxx15B820000 - ssid: net_ac_5B82

I have a Nexa S4E. The missing y seems to be an error on the dealers side. :smiley:

What have you tried to set things up? :slight_smile:

Hi @paddy0174,

Hmm, same here, Olimpia Splendid Nexya S4E.

Well, I used midea-discover (had to adapt it for windows) to get the ID.
There it reported ‘unsupported’ (which doen’t make sense really, as ‘0xac’ should be supported right?).
It does seem to get the correct ID though…

Decided to ignore the warning and install the repository anyway.


But…it doesn’t seem to do much…>

Log Details (WARNING)

Logger: homeassistant.helpers.entity
Source: runner.py:119
First occurred: August 15, 2020, 8:57:56 PM (2 occurrences)
Last logged: 11:27:00 AM

Update of climate.midea_ac_09a601000011 is taking over 10 seconds
image

Anyway, it’ll has to wait, will leave on holiday tomorrow…to be continued :wink:

Same problem here, were you able to make it work somehow?

No luck yet, I went ahead and setup a Broadlink Mini to send basic commands for now.

has somebody tried to decipher the USB protocol between the wifi module and the AC? the wifi modules are somewhat unreliable: need to be repaired every month, at least for me. it would be nice to a mini computer (e.g. pi) directly to the AC’s usb slot.
Any ideas on how to get started on that project? I was thinking of snooping the USB communication using some MITM setup.

See https://github.com/reneklootwijk/node-mideahvac

2 Likes

Anyone have come across the SK103 usb device ?? can it be adopted to work ?? Currently I tried both default components for both Mac_zhou and andersonshatch with no sucess …


I think this project is a more promising solution for HA, it will bypass the whole cloud idea

…as does this component. It is working only via LAN, the cloud is not needed at all. :slight_smile: As you can see, your module is based on the work of the component here in this thread.

But nevertheless it is another way to get to it, I’m always happy to see more than one solution. But your module isn’t a component for HA, and it isn’t working right now, or do I misunderstand:

In the current version of this module communication using the WiFi SmartKey and the Midea Cloud and communication via a TCP serial bridge connected to the UART port is supported. Direct connection to the WiFi SmartKey interface via a local LAN connection will be added later.

But…a (fake) cloud never the less :thinking:

Correct, work in progress :yum:
(it is not my project either…i’m just monitoring it closely)

Depends on the model. :wink: Different models need to have the fake cloud, others don’t. My Olimpia Splendid (a labeled Midea) for example doesn’t. This component or better the underlying library does account for that.
It is a very deep project, and can be confusing… I need nearly an hour every week to read and check the Telegram group… :wink:

But as I said, please keep monitoring the new module, if it works, especially only internal (on LAN), it would be great to have an alternative. And the HA bit (the custom_component) shouldn’t be hard to implement, if the module is ready. :+1:

An intresting differentiation there. “OSK-103”. The previous attempts were based on the OSK-102 usb stick. Newer models (like xreme save) use the 103 variant.

I managed to setup Mac_zhou’s component through HACS successfully.

Quick Question… is it expected that it takes 10s for the AC to receive the command and turn on or off for example?