Any Support for Midea A/C?

Hey @aceindy,

It’s almost everything clear now :slight_smile:

I’ve already put in my cart the following:

2x https://www.aliexpress.com/item/4001238357707.html (option with ESP-01)
2x https://www.aliexpress.com/item/32985707091.html (just the ESP adapter, put 2 in case I do disasters while soldering the mod with one of them)

With the time I have to wait for them to arrive and the xmas break, I’m pretty sure the MideaAC pull request will be implemented into the main rep once I’m ready and all set up, so I will probably use the “programmer” embedded in the EASPHome.

Remaining doubts:

  1. Why should I mod the ESP-01 if I already mod the ESP8266 to program it?
  2. I will check if I have the other cable to connect to the AC but in case I don’t, what cable should I buy?

Thank you a billion and sorry for all the (probably dumb) questions!

  1. Only the programmers hardware is modified (to put it into programming mode).
  2. Any USB cable will do (i cut off the connector on one side)

ps, very confusing that the terms esp01, esp8266, serial programmer seems to be mixed up everywhere…

so to be clear
2x


and to program it
1x image
or with soldered links to put it into programming mode

And asking questions is never dumb…people not asking them stay dumb :wink:

2 Likes

Hi @aceindy,
Amazing!

You just cleared all my doubts! I’ve already ordered everything and will probably receive the stuff by mid January (I think).

For now, thank you a billion for all your time and patience, hugely appreciated! :slight_smile:

Just adding my interest here, seems this will help a lot as the wifi adapters tend to disconnect from the network quite often.

the esp01 still utilizes wifi, so that won’t solve a poor wifi reception…

However, i my case it did solve the poor connection with the cloud, as each evening that one seemed to be overloaded :thinking:

Hi all, I’m quite new to HA.

I was trying to connect met Midea A/C to my HomeAssistent. I have it connected on my Android phone (with the NetHome Plus app) and can control it with my Google Assistent and with my phone.
I added the midea integration on HA (added it to custom components and added it to the configuration file). I found my deviceID but I can’t find my IP number. If I log on to HA it says that Midea is not available. I already tried with Angry IP Scanner but I can’t find the IP number. Can somebody help me?

Hi Joerie,
You need to check the connected devices on your home network in your router, also you have to reserved the IP.

Yes I tried that yesterday but I can only see connected MAC addresses… (no IP address, no description, nothing…)

Okay, I found the correct IP Address but still it shows ‘unavailable’ in HA. Any suggestions?

If all is setup well then its probably an unsupported device. Either wait if someone integrates this device or follow the alternative usb stick (check aceindy’s posts) with esp

@aceindy
Thanks again for bringing up the “ESP project” and for monitoring it! :+1: :+1: :+1:

As it seems, the project is in a working state now, would you mind starting a seperate thread for this? I’d be happy to assist with that, especially as I feel, this really valuable information is kind of lost or burried in this thread under a lot of other things.

I (and I’m sure a lot of others) would really appreciate it! :slight_smile:

Done --> Support for Midea A/C

3 Likes

Just installed an Ariston Split Air conditioner, and it connects to appsmb.com as the midea units and the “Ariston Clima” android app seems to be a clone of the midea app, so it should be possible to use the cloud integration by @andersonshatch With this unit. I’ll will do some testing and post some conclusions!

I confirm it is working with midea cloud (I had to configure it through midea app as “ariston clima” app is very buggy). It is working on my HA instalation via cloud (the unit is on a remote location, so lan control is not an option for now). It as the fan issue, so I had to use the ‘use_fan_workaround’. Model is Ariston Alys R32 35.

Hi - I have a new split AC - Midea with their supplied Wifi dongle - ran midea-discover : & found unsupported 0xac. Lan Intergration also unresponsive.

So what are my options - I tried the cloud intergration but it is very slow and stops working after few hours requiring a restart. Do I need to go the route of esphome as per - : Support for Midea A/C

Or are there some cleaver people adding more devices to the Midea Lan intergration ?

I’ve been backtracking the Telegram history, and as far as i understand the ESPhome usb dongle will support 0xac

Thanx, did try follow Telegram , but difficult from joning in last few days. Have ordered hardware. Now just the long shipping wait.

If you want to be 100% sure, why don’t you just ask ?
You’re on Telegram already anyway :thinking:

I appreciate all the work that has been done reverse engineering this and putting everything together. Y’all are amazing!

I’ve read through everything I can find and I’m just hoping to see if anyone can confirm that this applies to Pioneer units as well? It would seem so as they use the “NetHome Plus” app as well and the dongle is the same “Smart Kit” unit. I noticed this also goes by the same part number “OSK103” for Midea.

I also found that a dongle oddly similar to the mideahvac-dongle is listed for this series on Home Depot That one shows a different installation document than the one for the mini-split above. Again, it’s different because they use the “Cielo” app here.

Speaking of a Pioneer WYS units like WYS-19 9k BTU

As a side note; It looks like Mr. Cool uses the same “Smart Kit” dongle? which would make them compatible too?

I’d love if anyone could shed more light on this or confirm any of this.

I’m just hoping to clear this up for myself and possibly others in the future. I apologize for the wall of text and I hope it’s not any more confusing that this product line…

I have the exact same model. Could you please explain me what you did to integrate it in HA? I was able to add it into Midea’s App, but I can’t find any way to find it in HA…