Any Support for Midea A/C?

@nuggets yes also mr cool is working.
And i think everything with osk103 :sunglasses:

@AlessandroTischer all relevant info was transferred to this topic (it uses esphome)


:wink:

So the only way to integrate the ac is with new hardware? :cry:

No, you can always take the custom_component from @MacZhou. This works with the original OSK-102 (or something like that, the original hardware).

Go to HACS and search for " Midea Smart Aircon". This component works as well, with some small errors like taking longer than ten seconds to update, but it is stable that you can run and control you A/C. :slight_smile:

Here is the link to th repository:

1 Like

Unfortunately I’ve been trying to use that component for almost a month now, but without any success… The entity is created but remains unavailable. (if you give a look at the issues in ghat repository, you’ll see that I opened the latest one, just a couple of days ago)

This is why I was asking @n0t, since he also has my same hardware

Than debug the errors in this component or buy new hardware… :wink: Sorry, no other choice, as both components are relatively new, and so far working in most cases. :slight_smile: There is no need for a different, third component.

If you ask me, I’d invest in new hardware, it is not very expensive and so far the more reliable component (for me personally).

If you want to debug, you should provide some logs and data about your installation, maybe someone can help. I went the route with new hardware as all is open source and local, that fits my need perfectly and the cost was around 15€ to 20€. :slight_smile:

I am using the cloud integration by @andersonshatch (it is on a remote location from my HA server so didn’t test the local version). This is the version I’m using, installed via HACS and inserted the suggested code in configuration.yaml: https://github.com/andersonshatch/midea-ac-py

1 Like

Expensive…my esp + adapter was approx €5 a €6 :thinking:
Had to wait for shipment a while though :sunglasses:

Hi all and happy Easter to everyone :rabbit2: I’m new to HA.

I’ve been trying to integrate my 3 Midea air conditioner but I’ve an issue.
I installed @mac_zhou component and it works great…on 2 air conditioner only. One is missing.
The air conditioner Is connected to my router and I can see it online. Also, I can command trough the Midea app.

The IP address is correct. The device ID is correct. But still not work. :face_with_raised_eyebrow:

Someone can help me, please?

I’m not sure, if this component is still under development, at least I haven’t seen progress in a few months. mac_zhou is involved in the development of the new component.

You should try to use the new component for Midea A/C that works with an ESPHome based approach.

This component here: depending on what Midea dongle you use (OSK-102 or OSK-103), you may have to setup a local “fake” server or it works via the Midea cloud.
The new ESPHome component: works 100% in your local environment, no Midea cloud or fake servers.

Unfortunately I’m not an advanced user :sweat_smile: I’m still confused about HA and I don’t know how to do that dongle :rofl:

I’m using OSK103 in every A/C that I have but I don’t know why one of these doesn’t work. It’s quite strange…
I’ve also tried using @andersonshatch’s component that connect through Midea cloud but 1 out 3 still doesn’t work

I’ve also some problem installing msmart…

what do you mean? How can I achieve that?

Not a problem, but not being an advanced user is especially with this kind of component tricky… :wink: It needs a few things worked out behind the scenes and that makes it difficult to debug. In your case you’d need to get logs from all three of your dongles and debug them accordingly. In short words, this is something an experienced user could/should do. :slight_smile: I’m sorry, but I don’t use this component any more, as the ESPHome version is much more local and stable, easy to maintain and it is very inexpensive.

What I could offer you is: I’m writing on a tutorial for the new ESPHome based component, should be ready in a few days, and it will guide you step-by-step through the process of getting the parts, setting it up and use it. I’d strongly suggest to make the change to this component, as it will be actively maintained and is way easier in the end, than the one from this thread. :slight_smile:

2 Likes

Thank you. You’re my hero :smiley: I’ll wait patiently the tutorial :upside_down_face:

I have the custom component setup following the instructions on the github page, including adding the lines to configuration.yaml with the device ID and IP address, but I’m not seeing anything in my Integrations and the device/entities don’t appear. Am I missing something?

The only thing I do see in the logs is that it’s complaining about no versioning in the manifest but I don’t think that’s the issue is it?

2021-04-06 09:53:30 WARNING (MainThread) [homeassistant.loader] No ‘version’ key in the manifest file for custom integration ‘midea_ac’. This will not be allowed in a future version of Home Assistant. Please report this to the maintainer of ‘midea_ac’

I had the same problem. I installed the integration again and right now I see the device but it says it is unavailable. I installed it again and even reseted HA. It didn’t help and still idk what happened. I am sure that I have correct data put in the configuration.yaml

Can someone help?

@byronbrewer and @Raensl

Guys, come on, a little more information would be really useful to help… :wink: Something, no, anything will help. :slight_smile:

Your config looks like? What dongle are you using, what model/manufacturer is your A/C? Does the log say something? If not, have you enabled debug for this component (or don’t know how to do that)?

Come on, this shouldn’t be a guessing game. :slight_smile: :slight_smile: :slight_smile: So go, collect as many information that you might think could be useful and present it to us. :wink:

Yes, you are, otherwise it would work. What exactly? I have no idea… :wink:

If you are sure, everything is correct, than we are as well. :slight_smile:

You get the idea: Help us to help you! See here, especially points 8 to 14. :wink: How to help us help you - or How to ask a good question

so can u help me where can I get specified log/data about my integration. maybe then I could ask a good question. Right now in the log there is nothing about Midea so I may do something wrong :smiley:

We are talking about Anderson/MacShou’s solution with OSK-103 here right??

I’m not even sure that is still developed.
Fair change the OSK-103 got updates that are not in the repository of Anderson…
I can see there are still updates, but they all concern HA…
Makes sense, as his OSK won’t received any updates…

I too recommend to dump the OSK and get ESP :wink:
(if you manage to sell it for a recent price, you can buy may ESP for it :P)

This thread is about Midea A/C units so I didn’t feel it was necessary to specify that level of detail but if it’s helpful I have no problems doing so. I installed the integration from HACS and then plugged the information into configuration.yaml and restarted HA. Not sure how to enabe debug for the midea integration.

Make: Midea
Model: MAW08V1QWT
Add’l Info: It has a built dongle that’s concealed behind the front panel. It’s just a USB dongle that with a sticker that says “smart kit intelligent” on the sticker and has a MAC address. I would imagine it’s just a WiFi dongle but no idea beyond that

This is the section I added to my configuration.yaml. I pulled the device ID by doing a Share from within the Midea app, pulled the data out of the QR code and then converted the string to text.

climate:
  - platform: midea_ac
    host: 192.168.29.111
    id: 012345678901234

After adding this to my config and restarting HA I do see an entity was created but it says it’s unavailable.

Pretty sure the integrated wifi stick in your unit is the newer, hereby often referred 103 one, which is not supported by the HACS Midea AC integration.

Bummer. Is there a way to buy a different dongle that would allow me to control it from HA?