Any tricks to getting all lights to come on in a group

I have a bathroom light fixture that has 6 bulbs, I have them set up as bath1, bath2 etc as well as a group containing all 6. when I create an automation via node-red or Home Assistant sometimes all of them turn on or off but most of the time they don’t making the wife unhappy to say the least.

Tell us more. What technology are these bulbs? How are they integrated In ha?

These 6 bulbs or EchoSmart Zigbee bulbs, integrated via ZHA on a ConBee II. Individually entities are Master Bathroom Light 1, Master Bathroom Light 2 and so on. confiruration.yaml looks like this:

 - platform: group
    name: Master Bathroom Light Group
      - light.master_bathroom_1
      - light.master_bathroom_2
      - light.master_bathroom_3
      - light.master_bathroom_4
      - light.master_bathroom_5
      - light.master_bathroom_5
      - light.master_bathroom_6

I use zigbee2mqtt, but the principle should be the same on ZHA I think.

Put the bulbs in a zigbee group, not a home assistant group. That fixed my z2m setup. Not sure exactly which buttons to press to do it in ZHA though.

Thanks, makes sense off to search google to learn how to do this.

Found out how to generate the zigbee group and did so but it didn’t have any positive affect. I still get some bulbs that randomly stay on when turned off and vice a versa.

And out of interest, what happens if you assign them all to a Bathroom area in home assistant, and then use the light.turn_on / turn_off service with the area instead?

Same thing, I get random bulbs that don’t turn on or don’t shut off. There are times when motion triggers and all lights come on but only some later shut off and vice a versa. The apartment is small, I have a total of 18 zigbee devices and the Home Assistant appliance (raspi 4 is about no more than 10 feet away from and one of these devices

I’ve had something similar happen with ZWave and even RF sockets - and it was always because there were too close together and causing interference with each other. If you always want all 6 bulbs on or off, why not instead look for a Zigbee relay that can sit behind the light switch and turn the entire light fitting on or off. It’s worth looking at humidity in the bathroom too - 2.4GHz is the most efficient frequency for water to absorb the signal (that’s why Microwaves run at 2.4GHz) so if the bathroom has high humidity the signal might be getting degraded.

As for interference, don’t forget that what is really going on here - is you are asking 6 lights to turn on (or off), one or more of those lights will have decided that rather than talking to the Zigbee coordinator directly - they would prefer to talk via another lightbulb. So not only are you sending signals telling the lights to turn on or off, but those signals are being repeated likely several times by different light bulbs, which may be too close to the light that the message is intended for - causing it to become momentarily “deaf” because the signal is “too loud”.

Appreciate you sharing your experience and insight. I’ll look into the relay idea.

1 Like

Additional - you mention that the apartment is small, so it may be worth considering whether or not your WiFi is interfering with the Zigbee signal - here is a handy YouTube video explaining which Zigbee channels you should be using and which WiFi channels. ZigBee and WiFi Interference and Coexistence - YouTube

Thanks, am off to look at it now.

1 Like

Doing as you suggested seems to work. I think I tried this out too soon and didn’t give the zigbee network time so sync. Additionally I individually reset each of the 6 lights brightness and color temp think this might be a sync problem. In any case it is working longer than it has before in that all lights come on and go off together. Thanks for the help.