Any way to remove old devices from google home?

I realise this is more of a question for google than here, but the threads I found in google’s forums for this general issue didn’t seem overly promising so I thought I’d see if anyone here has hit this issue…

A while ago I was running and I had a go at google assistant linking. which was mostly working. Since then my SD card died and when I replaced it I used the opportunity to try HA via Docker instead. I now want to give the Home Assistant Cloud a go, partly for the simplicity and partly to support HA.

Anyway, all my old devices (including loads of defunct ones I never really wanted there anyway) are still showing in my google home set-up, though they obviously no longer work. I’d like to remove them all to start afresh, but I can’t work out how to do it. There doesn’t seem to be any option in the google home app to do this and if I ask google to “sync all devices”, it says “sorry an error occurred whilst syncing”. I guess I need to remove the service from google home, but I can’t even see that listed anywhere. I can see “homeassistant” listed in my Google Cloud Platform account, with “shut down” as an option. Should I do that? Thought I’d better check first in case that might make it even harder to sort out the old entries!

1 Like

Ah, it looks like this was sorted by simply creating a new “Home” in Google Home!

One would hope there’d be a less drastic solution than starting a new ‘Home’ just to get rid of stale device entries.
In my case (using 2021.8.1) I’ve tried (each one separately) shutting down HA, deleting .storage/cloud, disconnecting Google Home from HA (NabuCasa) and reconnecting, unchecking all the devices exposed to Google, and a few other wild attempts.
In no case did the stale entries depart from Google Home.
A bug in GoogleHome? Or a cached set of stale entries at NabuCasa (if it caches)?
Just guessing at this point. Hoping someone who knows this integration can suggest a solution.

I created a new home, but immediately after I notice “Linked to you” in the bottom of the new home, that still contains all the old devices I’d like to get rid of. I wish there was a better way to do this. Only option I get is to remove My Homeassistant integrations, but that will remove all devices, including the ones that work (I assume).

This happens to me occasionally, e.g. when I am changing devices’ names to repurpose them, if I forget to first change its setting in the Google integration to “don’t expose entity” before changing its name or deleting it in HA.
A sort of ‘zombie’ copy of the device persists in GHome, but has ‘offline’ or similar status there.
They do go away eventually.
I have tried - and still do when this happens - telling Google Assistant “resync my devices” but that doesn’t fix it immediately, and there appears to be no way in Home to forcibly remove a device without disabling GHome’s link to NabuCasa.
I just move the zombie entities to a fake ‘room’ where they’re out of the way for the time being, and in a few days they vanish on their own.

Hmm @glyndon. OK thanks for your reply. I’ll give it some days!