Any Way to Use ha bridge with Home Assistant

I was hoping to use my Echo with Home Assistant. I really don’t have the time or know how to configure the Echo component, so I was hoping to use ha bridge. I see that with this you can add unsupported devices that have a REST api. I tried to add a few lights, but can’t get anything to work. Is there a way to use this with Home Assistant? If not is there a plan to possibly leverage something like this in the future to make Echo integration easier?

There’s a feature request on ha-bridge to enable custom headers on ON and OFF commands. Until that’s enabled then no, but once it is then definitely yes.

Version 2.0 of the ha-bridge just released, with header support.

I wrote a little blog post on it, FYI:

1 Like

Do you have https setup on your Pi?

I have ha-bridge and HA running on the same Pi, mostly without issue (i.e., the Harmony and Nest modules work fine). But I haven’t been able to use ha-bridge to trigger anything on HA via the API. Whether I set the turn_on/off URLs to http(s)://(localhost or the actual domain) ha-bridge complains:

Jun 16 15:28:30 raspberrypi java[3217]: 2016-06-16 15:28:30,373 [qtp32512300-17] WARN  com.bwssystems.HABridge.hue.HueMulator - Error on calling url to change device state:
Jun 16 15:29:08 raspberrypi java[3217]: 2016-06-16 15:29:08,615 [qtp32512300-17] WARN  com.bwssystems.HABridge.hue.HueMulator - Error calling out to HA gateway: IOException in log
Jun 16 15:29:08 raspberrypi java[3217]: PKIX path building failed: unable to find valid certification path to requested target

So I’m wondering if this issue has to do with the use of https.

The website is down?

Hi, HA Bridge is functional as is discoverable by the Echo. However, when I test the Bridge device to turn on my MiLight bulbs within Home Assistant, these are the errors I receive:

12-29-2016 23:37:27.833
Error calling out to HA gateway: IOException in log
12-29-2016 23:37:27.857
Error on calling url to change device state: https://MYIP:8123/api/services/homeassistant/turn_on

Thanks In Advance.

I have the same issue as the above, Error on calling url…
Any suggestions?

Not much info to go off but the first thing I notice is https:// - if you are using SSL and LetsEncrypt you need to do some stuff to get it working with Ha Bridge. See Linked post if that’s the case.

In the meantime I did find that post and have it working now, thanks.

aaronwolen’s blog post discusses getting hass devices into ha-bridge, but has anyone been able to get ha-bridge devices into hass? I.e., detect ha-bridge as a phillips hue hub? I can not get hass to detect ha-bridge. I tried adding it as a second line (I have a real Hue hub, too) in the phue config file, but that caused errors.

I have just come across this post - I use HA Bridge with my Home assistant - the latest version (4.1.4) has home assistant integration. Works really well and you can choose what HA devices to integrate and rename them etc.

1 Like

Anybody still “working” with this I have it running for my older setup but the new one the test buttons work but Alexa can’t find the ID and run the command Idea will be helpful, I do not want to run a AWS server setup when have a solution running local

I was using HABridge for years up until about 1.5 months ago, when it again lost all my devices. So I switched to the Emulated Hue. It works as well as habridge, if not better. I had to find a different solution for my one last ancient X10 device which was being controlled by HAbridge, which I worked out using a script.

However, after I did all this, I figured out why HABridge lost all my devices. It was because I had moved them to a different vlan (subnet) six months ago and it took that long for these devices to get lost, as odd as it may seem. In the end, I have to keep ONE Alexa on the main subnet, while the others still remain on the Media vlan.

1 Like

Ok, Never lost a device, my problem is simply get msg from Alexa to see it, I did not have an luck with Emulated Hue also, , but My HSB runs on Docker default ports and is not made public none however Alexa is on the same subnet