Anyone able to control their samsung TV with home assistant?

Anyone using either samsung tv HA integration?
I can send a poweron command with the remote.turn_on service call, but for other keys like ambient mode or hdmi switching, i need the service remote.send_command. It does not work. However i also have to set a device ID here? (not needed for the remote.turn_on service)
where do i get that device ID? I only have the ip and mac address of the device.

Some help from people with samsung tv’s would be greatly appriciated!

anyone…? :sweat_smile:

I’m sure you probably figured this out by now but if you haven’t there are different options depending on what TV you have. At first, I thought I would be using WOL to turn mine on but found out that’s not supported with my model. I also tried using the Samsung integration but that didn’t work either with my model. Once l loaded the SmartThings integration I was almost set up. To access the remote I need a different integration and that’s why I’m searching on Samsung TVs right now. I deleted the integration to see if that cleared up a problem I was having now can’t remember which Samsung integration to use for the remote. Using the media player connection to the TV provides some options too.

find the device id by going to Settings → devices & services → Integrations tab → click on "Samsung Smart TV integration → click on “2 entities”
There will be a “media player” and a “remote” entity.

I’m trying to figure this out currently also - I’m able to successfully use those media player controls for a few things. setting volume, setting the channel, vol up, vol down, and turning the tv off.

for instance, my script to set the channel is as follows:

  - alias: media player - Change the Channel
    service: media_player.play_media
    metadata: {}
      entity_id: media_player.samsung_8_series_75
      media_content_id: 1035
      media_content_type: channel

Is anyone able to get the “remote.send_command” working?
Perhaps it’s just my TV, but instructions here are not working for me.
HA Samsung Remote section


I pretty much solved my own question. to get the remote.send_command working, you target the other entity, which is the “remote.samsung_8_series_75” in my case (obviously!).

Check out this