Anyone Else Having Tuya Problems?


This evening (21:30 ish BST) I lost the ability to modify my Tuya devices through HA (All OK through the Smart Life App) A reload of of the Tuya integration on HA resulted in all the devices/entities vanishing.

Further investigations in the Tuya IOT portal showed no devices in my project - WTF?? I changed data centres to Western Europe - No change, and then back to Central Europe where upon all my devices in the Tuya IOT were re-instated,

Tried a reload in in the integrations in HA - And a restart of HA - No devices found.

Deleted the initial integration - Restart HA - Added the integration (successfully in terms of login) - No devices or entities found.

Any ideas or suggestions?

It seems that I set up a free subscription to some of the APIs for a month - For example Iot Core.

It ran out today.

Looking at the subscription plans they are based on commercial users with significant spend to buy many millions of API cores.

  1. Is there a way of setting up Tuya to avoid this.
  2. Is there a HA “joint buy” scheme that I could subscribe to for Tuya, at say $5 per year (current usage is $0.2 per month.
  3. Have others had any success at discussing the matter with Tuya to allow low volume personal use in perpetuity.
  4. Any other suggestions.

I was aware of one API that required free trial and subsequent authorisation - But I never subscribed to than and all worked OK so I was assuming I would be OK for long term usage.

I’ve spent a good while setting up my smart devices using this integration and it seems I’ve been wasting my time.

I could, in theory, add my Tuya devices into eWeLink but that has been flaky in the past. In order to do that I’d need to understand how to use persistent variables within HA to set up statuses that I would need. I’ve been handling this with a Tuya virtual 4 switch device successfully up until now.

I know others will be telling me I shouldn’t be relying on cloud service, but I already had a mixed ecosystem and I can’t afford to be replacing $1000s of devices to make a pure HA system.

Besides, doing that means junking Alexa as it costs to integrate into HA.

What a bloody mess!

Maybe localtuya integration can help you out

1 Like

After much digging around it turned out my Toya IoT Service API for Basic IoT free subscription had ended.

I applied for a 6 month extension, which has now been granted.

Has anyone had any success doing repeated extensions of their service API for Basic IoT?

If not I’ve 6 months to find another solution.

Just created new account, moved device there and redo integration setup. This i can do for long time. Local tuya hebt worked for me yet

Found this link in the official documentation: Tuya - Home Assistant

Not quite sure how this can be right for an officially supported integration for HASS but it’s there so…