Anyone found an integration for "Smart Stove" pellet stove app?

I just put in 2 pellet stoves from Cleaveland Ironworks. The App they use is called “Smart Stove”

Anyone have any integration ideas?

EDIT: this is just a crappy rebranded Tuya app, see below for how to replace this garbage with complete local control.

Jeff

1 Like

any luck so far?

No. Smartlife has a weak integration and the value of the current temp is wrong. I gave upon this and put my own temp sensors in the room and control the stove that way, especially when the stove goes into failure mode.

Jeff

I just bought one of the Cleveland Iron Works stoves, and while integration with Home Assistant is not at the top of my list, it would be cool to do. I already have a temp sensor in the room where the stove is, I’m wondering exactly how you control the stove? Is it with a smart plug or something like that? (I’m hooking the stove up today.) Also, what do you mean by “failure mode”?

Thanks…

Oh boy. Which version of the stove?

And, You’re in luck. Its all spelled out here in gory, technicolor technospeak:

The story of my journey over the past year and all my trials and tribulations of conquering this frigging stove.

If you’re willing to be a little bit adventurous, I’ve rewritten major parts of the firmware while keeping all the safety protections of the stock unit, and you can do the same. Mine has been burning now all day and night for a week without going out once and regulates the room temp perfectly. Minimal pellet use (maybe 3/4 bag a day) and the glass is completely clear as opposed to covered in soot. It only took me a year to get here, but is working flawlessly.

The factory programming on these stoves is absolute CRAP. Some of the worst embedded control system code Ive ever seen. These stoves are anything BUT smart. It’s what you get with cheap Chinese slave labor and cost cutting manufacturing and products rushed to market. However, these stoves are all in good company. Most brands these days are all built in China and suffer from many of the same limitations and problems. So, you get over it and brute force fix it.

The good news is that all changes with my mods. You get complete control over all functions including fire pot burn control if you go all the way. Or, just replace the wifi chip firmware and use ESPHome. That at least gives you all the correct display controls in home assistant which you can then run automations against.

Step #1 - if you’re uncomfortable jumping in full hog right away, call the support number and tell them you’re wifi module stopped working. it worked for a day, now no response. its been that way for a month, but the stove has been working ok. Now the igniter doest work and that’s why I’m calling. You want them to send you a new Display unit and a new igniter. You igniter will burn out in a year. Trust me on this!

Then you put my basic ESPHome code into the wifi module and you have full home assistant integration. It replicates the display in all user mode functions LOCALLY. No more Chinese controlled Tuya cloud.

Honestly, Ive programmed 5 of these wifi modules at this point and if your ok soldering the small pins on the TYWE1s chip, you can’t really screw it up. the chips are almost bulletproof. meaning there’s not much that can brick or fry them. all the pins are gpio signal level, so shorting them has no effect, AND they don’t do anything. That chip is ONLY there for wifi control, literally NOTHING else. in fact, you can take it out and the stove functions fine, you just have no wifi control.

Step #2 - modify the controller board (it has all the wires running to it at the bottom of the stove) by cutting ONE trace and running 2 new wires to the display unit. And then you have a truly SMART Pellet Stove.

Use the discussions section or problems section in GitHub to ask me anything. I know these stoves better now than anyone in tech support at Cleaveland Ironworks, and you can take that to the bank!!

Jeff

It is a Cleveland Iron Works PS20W-CIW Mini Pellet Stove, WiFi Enabled, 18 lb Hopper Capacity. Still in the process of installing it, hopefully tomorrow I’ll be able to fire it up. So at this point no idea which firmware or firmware version…hopefully I’ll have that info tomorrow. I’ll probably use it as-is for at least a little while, see how annoying it is, then probably at least reflash the wifi chip.

Its the same as all the rest, just a smaller hopper.

reflashing will give you a lot more control at the very least. putting an ultrasonic pellet level sensor on a couple unused gpio pins of the TYWE1S is also VERY worthwhile!

Wow, you weren’t kidding! The app is definitely terrible! Definitely going to reflash…I know I’ve seen your comments on how to do it (I’ve reflashed lots of devices, mostly Sonoff and nodemcu devices with Tasmota) I just need to find them again. Many thanks for your efforts!

It’s all spelled out in gory detail on my github. ! Pretty easy really!

Yep, after I hit “send” I found that again. Was hoping I could just find the chip on Amazon or somewhere, no luck though. Trying to get a price on a new display from CIW. If it’s ridiculous I’ll take my chances and flash the one I have, if cheap enough I’ll buy one to have a backup.

Where are you located? I have a couple extra of these. I could flash one and swap one out if u sent me yours back? I’m happy to help!

I’m in Viola, Delaware. Just got an email from CIW, apparently they have no stock, only replacements under warranty. After looking at the TuyaMCU instructions I think I’ll take you up on that, it looks a bit beyond my rudimentary flashing skills! So just pull the chip and mail it to you? Sounds good!

wow. you must be close to my age (63). Netscape in the beginning, I remember that! Windows 3.1 w/trumpet winsock over 14.4/28.8 dialup! (I was in Japan (Okinawa actually) at the time, 1994 I guess?)

58 here. And I worked at Netmanage in '94. I was selling TCPIP stacks and apps for windows. got killed by msft when windows95 came out so I went to Netscape - in the very beginning. I got killed by msft there as well when they gave away their crappy browser for free. Then went to RealNames as VP of sales. Got killed by msft there. Sense a theme? :slight_smile:

This link shows you mostly how to do it: TuyaMCU Devices - Tasmota

FLASHING, if unplugging the module from the display, I used 3.3v, U0TX (goes to RX on the FTTD adapter) and U0RX (goes to TX on the FTTD flashing interface adapter) and the Ground. And then I only grounded GPIO0 at bootup to flash the chip. remove this ground from GPIO0 after its flashed. Also, connect 3.3V from your FTTD adapter (not 5v) to the 3V3 pin on the TYWE1S chip, pin 4,

WARNING - be careful when you solder wires to the board/chip to flash the chip. I used breadboard wires w/pins and my VCC connection broke at some point and it took most of the circuit board trace off both the board AND the chip. I salvaged it with a Frankenstein jumper, but you’ve been warned! Just be careful and you should be fine. It’s next to impossible to brick that chip.

its all here GitHub - jazzmonger/wood-stove-with-TYWE1S-Tuya-chip

Oh yea, I’ve hated microsoft since around 1997, when I discovered lInux. Been an open-source advocate ever since. Yea, I read through the TuyaMCU stuff, seems quite a bit more involved than flashing a sonoff or nodemcu device with tasmota, etc. I may give it a shot at some point, it’s a bit unclear how to actually flash it. I’ve used tasmotizer and esptools, pretty straightforward…maybe I’m just dense, but the tuyamcu seems more complicated. Of course I haven’t done a hard search for it yet, I’m sure that would shed some light on it. Ah, google, there’s another company I now despise. I worked at an ISP the day google went live, it was awesome. But then they went from “Rule 1 - don’t be evil” to “Rule 1 - make money in any way possible, screw the user.” At least that’s how I see it. They are now as bad as apple in that respect, imho. lol. old-head computer guys rule!

Oh, almost forgot…send me your payment method info and I’ll send out the cost of shipping the chip to me.

And you’d be correct there! Once I fully understood how all the little bits fit together and how ESPHome fits in with that convoluted eco system, everything clicked and I rocketed toward a pretty elegant solution. I might put together a little wiki page on all this. If it’s confusing to me, a trained electronics engineer & programmer, I can only imagine how complicated and black boxish it might appear to the average Joe.

Google… a whole bunch of the sr. executive idiots and woketards I worked with at Netscape ended up there. Some core facts: They are ALL 1) rich 2) extremely unhappy people 3) divorced multiple times 4) living in an alternate reality from the rest of us completely devoid of morals 4) embrace the police state and have no respect for privacy or the American way.

Thankfully I escaped ALL of that w/ my sanity intact & never looked back. I avoid all Google products at all costs. They became everything Microsoft was/is and MUCH, MUCH worse. I go as far as saying they are the single most evil company on the planet. Go ahead, ask me how I really feel!

Oh, I just finished flashing your chip - it’s literally in the mail.

I suspected as much (of google), good to hear it from someone with actual knowledge. I agree, I actually had 5 or 6 google home devices, so a not-insignificant investment. At some point I get fed up with the inability to actually reset everything and start over with a more cohesive plan (it was ad-hoc at best, built over time) and took them all out back, drilled a 1/2" hole through each device and threw them in the trash. Also had a chromebook, threw that in the trash as well.

Anyway, what app did you use to flash the chip? I was assuming (yea, i know!) it would be esptool, but I guess that’s not the case. Now that I will have a working solution (thanks to you!) I will finagle another chip out of CIW and work on that process, as I can see another pellet stove in my not-too-distant future.

Cheers!

oh, and tracking # for your inbound chip is 9405 5036 9930 0463 9513 20

I just use ESPHome Manual download option to flash using the ESPHome web app with Chrome (one if the only times I have to use a Google product). Super simple.

I have used a 3D printed jig I made with pogo pins in the past to flash these TYWE1S chips, but in this case, I soldered and left the 4 little pigtail wires I used for flashing on the chip in place just in case you ever want/need to do it again in the future. It’s a royal PITA to solder them on, so now you don’t have to! They won’t hurt or touch anything with the plastic display back cover screwed on.

OK, I think I can do that with the ESPHome addon in Home Assistant. If not then I know the web app of which you speak that requires chrome. What file do you actually flash to the chip? I don’t see any binaries or anything that looks like a candidate for flashing? I just see some yaml files.

“adopting an existing ESPHome device with new config file” ← in case someone else searches for how to do this. I struggled w this at first also. For this to work, the device name MUST be the same in the config file as well as the ESP (it is in your case). otherwise you have to use the fixed ip address of the ESP in the wifi section of the config file

Its all built into the ESPHome integration in home assistant.

ESPHome uses yaml files - ESPHome compiles them into a binary and flashes those, its all automagic if you use ESPHome in home assistant. Once your device is adopted, all the options are there.

1- plug in the chip I sent you and turn on the stove
2- home assistant will discover it. go to settings/Integrations and “adopt it”
3 - Now follow this from the ESPHome dashboard:

image

back to the ESPHome dashboard:

Delete the example code and copy & paste the file I sent you in your PM:

Save it. Then in the ESPHome dashboard, choose Logs/Wireless on that device and you should connect to it and see it chugging away.

You can also edit the file and then upload wirelessly. Just be careful if you chg the WiFi info… I haven’t tested the fallback hotspot on the TYWE1S chip. USB logs don’t work on that chip, so there may be other functions that don’t work - Im not sure there…

yay, my chip should be here today (as should yours), I’ll get on that as soon as the mail gets here. Pretty cool that the binary is compiled that way. (My background is in networking; CCNA, etc. I’ve tried many times over the last 30 years to learn programming, but the light bulb never came on. I just don’t get it!)