Anyone got live camera feed working properly on raspberry PI 3+ (post 0.92 update)?

Seeing as though 0.92 update of home assistant says it has live feeds I have decided to go ahead and add my IP cameras that currently I run through other software into lovelace occasionally the card display the whole camera perfectly but more often than not it is majorly blurred like below.

Seeing as though it works sometimes but not others I am thinking my raspberry pi3+ is not keeping up with the rendering requirements. Before I added a camera into the front end I had about 1% CPU and 15% RAM utilization. Now you can see just one camera is adding abit of strain on the PI

In motioneye the camera displays live feed flawlessly which it on rtsp feed so the PI can handle live cameras through dedicated addon. I tried changing my settings in my camera.yaml file to rtsp address but it in lovelace it was unable to load the feed.

camera.yaml (port 80)

camera.yaml (rtsp doesn’t work)

rtsp card with above change


If motion eye can do it and 0.92 puts positive spin on support for live feed in cards I must be doing something wrong in my settings does it need to come from the rtsp port is port 80 feed to large?

This is what things looks like with motioneye open with 3 cameras running :rofl:

I have started looking upgrading my hardware host from the Pi3+ I am only just getting started with home assistant and the Pi doesn’t look all that powerful. My reboot times have also punching above 5 minutes now which is annoying when many of the changes in home assistant require a reboot.

Found this looking for an issue with freezing live feed.

I also go this blurred image some times.

Have you made the step to new hardware and if did it fix the issue.

I got rid using the Pi3+ which is collecting dust now. I am not saying the Pi3+ doesn’t have a place for small time stuff, but you start running Home Assistant and Node Red on plus other stuff it can’t keep up.

My computer at home is never turned off it was running Plex and my CCTV ( software pricey but simply amazing) it was running a i5 CPU which was running around 70% to 100% load most of the time but not affecting me using it.

I looked around at solutions to replace the Pi but all involved another system and all I did was pull my i5 CPU out list it on ebay buy an i7 coz i7 have hyperthreading once that was installed the CPU on my computer was happily working through tasks.

I then installed Oracles free Virtual box in it and migrated and the CPU is only under 43% load running quiet alot of background processes.

So I stopped using the camera software in HA prior and did not try it again…But I fix the weak CPU issue by migrating away from PI