Anyone help me getting ebusd to work please?

I have connected a Raspberry Pi to my boiler’s ebus via a USB adapter and confirmed that I can read the bus using ebusd.

Now I have installed HA on a new SD Card and I’m trying to get the core ebusd implementation to work. Here is my config file:

  circuit: "bai"
  name: "Vaillant"
    - FlowTemperature
    - ReturnTemperature

This is the error I get when I restart HA:

Logger: homeassistant.setup
Source: components/ebusd/
First occurred: 21:26:38 (1 occurrences)
Last logged: 21:26:38

Error during setup of component ebusd
Traceback (most recent call last):
  File "/usr/local/lib/python3.10/site-packages/ebusdpy/", line 14, in init
ConnectionRefusedError: [Errno 111] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 235, in _async_setup_component
    result = await task
  File "/usr/local/lib/python3.10/concurrent/futures/", line 58, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/ebusd/", line 70, in setup
  File "/usr/local/lib/python3.10/site-packages/ebusdpy/", line 18, in init
    raise EBusError(socket.error)
ebusdpy.ebusdpy.EBusError: <class 'OSError'>

Any help on sorting this will be very much appreciated :grinning: :grinning:



Looks to me like ebusd is not listening on the localhost interface of your RPi?

Try sudo netstat -ltpnu and see if you see ebusd listed. Share the output.

Thanks. Here it is:

[core-ssh ~]$ netstat -ltpnu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0*               LISTEN      -
tcp        0      0  *               LISTEN      138/ttyd
udp        0      0*                           -

My adapter is connected via /dev/ttyUSB0. Do I need to specify this anywhere?


Nono, you have to run sudo netstat -ltpnu to see which processes (PID column) are running.

I tried that from the HA Terminal but it didn’t work.

[core-ssh ~]$ sudo netstat -ltpnu
bash: sudo: command not found

I’m sorry but I only know about standard Linux. If there is no sudo there has to be another way to become root in that system.

OK thanks. I’ve parked this exercise for now as I’ve written a Python script that is reading the data I want and writing it to a file. I’ll come back to HA another time.


1 Like

I am having the exact same problem.
I have installed the ebusd Add-On by Lukas Grebe and the ebusd Integration via HACS.
My ebusd hardware is connected to the LAN via WiFi, the Shield interface says “ebusd device string: ens:”

I do not know exactly how to configure the Add-On. I have tried two settings on the Configuration page: Mode: ens and Network Adapter Address: ens: as well as
Mode: udp and Network Adapter Address: udp:, but both didn’t work, I keep getting the same error as Mike.

Any hints most welcome!