Anyone know much about SSL?

This just started today.
I can not access home assistant thru my on both my iphones and laptop.
If i turn off my wifi on the iphone then it will connect with no problem. But as soon as I turn the wifi back on i loss connection.
On my laptop the only way to connect to home assistant is local by https://mylocalip:8123
The funny thing is that I have two wall mounted android tablets that are connected thru that are working fine.
Anyone have any ideas what it could be?

Forget what its called (reverse NAT?) but basically your router doesn’t allow you to go OUT onto internet then back IN to PC on your private network?

Not sure what others have done as workaround for this

It’s called loopback or hairpin NAT.

Your router may support it but you need to enable it.

Not sure why the android tablets work… maybe chrome browser built in dns?

I checked the settings for NAT Loopback of my router and it is enabled.
When you said maybe chrome browser built in dns? it made me think. So I downloaded chrome for my lap top and it connected with no problem.
I had Pi Hole running on a pi so I shut it down but no difference.

Just wondering what Im missing.