Anyone using Nortek WADWAZ-1 door sensor "external switch" in Z-wave JS?

As title says, I am trying to use the external switch on a WADWAZ-1 door sensor.
This worked in the deprecated OZW1.4 integration by monitoring a “sensor.sensor_alarm_level”, where value “255” indicated the switch was activated.

The device has several entities in Z-wave JS:

  1. binary_sensor.sensor :this is the standard sensor when used normally with internal switch, but does not seem to change with external switch in my testing
  2. sensor.sensor_alarmlevel
  3. sensor.sensor_alarmtype : neither 2) nor 3) registers any values as far as I can see, but maybe the “alarmlevel” is not correctly configured in z-wave JS?
  4. sensor.sensor_basic : seems to always report “0”

If I am missing something obvious, please let me know.
If the configuration file for this device is incomplete, I will request a fix on github, any thoughts appreciated! Thanks.

I think the Z-wave JS config file is missing the following CommandClass present in OZW:

  <CommandClass id="112">
    <Value genre="config" index="1" label="External Switch" max="255" min="0" size="1" type="list" value="0">
      <Help>External Switch Status</Help>
      <Item label="On" value="255"/>
      <Item label="Off" value="0"/>

I have this device and it is working fine with Z-Wave JS add-on and integration.

I do have this in my configuration.yaml to get the correct icon in the main ui


# Windows
      device_class: window

Hi @VPC, thanks for your reply. I may not have been clear in my original post. Are you able to monitor the status of an external switch, that is one you have physically wired onto the internal contacts? I am able to use these sensors with the magnetic “reed” switch, but not an externally wired switch.

Oh, sorry - I misunderstood. I’m just using the magnetic switch.

1 Like

I am also using the device, but not the external switch. I have 3 enabled entities and 3 disabled, none of which are related to the external switch.

Have you tried putting HA in inclusion mode, and opening and closing the external switch? I have a hazy recollection that I had to do this with a similar device on another system.

Thanks for the idea, I may give this a try.
Meanwhile here are the specs for the various switches, maybe this will give someone an idea about how to properly read the external switch in Z-wave JS.

@blhoward2, tagging you in case you can guide me on the best way to improve the z-wave JS config file for this device. Thanks!

This is unlikely to be a config file issue. What you’re describing is a missing or misconfigured endpoint which isn’t affected by the device file unless a compat flag is needed, and we don’t yet have one that would affect this. The first step is to check under Values in the zwavejs2mqtt UI and see if that state is being setup as an endpoint. If it is, then the issue is that the integration isn’t creating a device for it. (I suspect this is the problem.) If the endpoint isn’t being discovered by node-zwave-js then you’d need to raise an issue on that project so we can have a look at the interview.


I ended up soldering a wire to each side of the reed switch to use as an “external” switch. This is working great for my application (sump pump alarm monitoring).

1 Like

I have this problem and don’t want to use Hackashaq666’s workaround. What do you need from me in order to help make this work?

Here is the vendor’s documentation:

Follow the steps I posted to confirm where the issue lies, then raise an issue on the appropriate project. The right people at the right project need to look at it, and they’ll need logs and node information to do so, which the bug template at whichever project will ask you to upload. The manual isn’t helpful.