AP on Raspberry Pi in 2020

Ehlo everyone,

I recently needed to get my Raspberry Pi 3 with Home Assistant and a wireless acess point. I need the AP capabilities as well as MAC spoofing on eth0 for connection. I went the RaspiOS route and everything works until I install Docker. It’s been months that I’m trying to make it work and no luck so far.

I tried posting on the RaspberryPi forums too there.

I read all the post on here along with some other on the internet. I think I flashed my SD card something of 50 times. I made a script for that :


sudo apt update && sudo apt full-upgrade -y

command -v jq > /dev/null 2>&1 || { sudo apt-get install -y software-properties-common ; sudo add-apt-repository universe ; sudo apt-get update ; sudo apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat lynx ;}

sudo systemctl stop ModemManager.service

sudo systemctl disable ModemManager.service

command -v docker > /dev/null 2>&1 || { sudo curl -fsSL get.docker.com | sh; sudo groupadd docker; sudo gpasswd -a $USER docker; newgrp docker ;}

command -v docker-compose > /dev/null 2>&1 || { sudo apt-get install -y libffi-dev libssl-dev python3 python3-pip ; sudo -H pip3 install docker-compose ;}

sudo sh -c 'curl -sL https://raw.githubusercontent.com/home-assistant/supervised-installer/master/installer.sh | bash -s -- -m raspberrypi3'

sudo nano /etc/sysctl.conf

# net.ipv4.ip_forward=1

sudo nano /etc/dhcpcd.conf

# denyinterfaces wlan0

sudo nano /etc/rc.local

# /sbin/iw dev wlan0 set power_save off

# iptables -I DOCKER-USER -i src_if -o dst_if -j ACCEPT

Has anyone clues as to how to have this seemingly simple feature ? Thanks !