Apache proxy to home assistant


We’ve been trying to get our Home Assistant proxied out publicly (on SSL, rather than port 8123) through our existing RaspberryPi server (that runs an ownCloud instance). Everything works great internally, but we can’t seem to get past a blue/white screen when trying to get to the Home Assistant instance.

Currently we have a load balancer that is the SSL-enabled, port-forwarded server (because it’s actually a small cluster) and we’ve tried putting an entry in the proxy_balancer.conf to direct traffic to the Home Assistant port, with no success.

We’ve also just tried following the steps in this post using proxy_wstunnel, but with a similar lack of results.

Our dynamic DNS is through NoIP, so we can’t have subdomains, we are trying to use a subdirectory as the destination, ie https://mysite.hopto.org/smart-home

Any thoughts, please?