Apcupsd on Proxmox & Hassio


I am new to HA, my current home automation is migrating to HA.
My config is an Intel NUC with Proxmox and hassio runs in one of the virtual machines.

I have an APC UPS in the power supply, I want that, just like I now monitor all with apcupsd, and if the battery voltage is too low I naturally want the nuc to be switched off.
for Proxmox that is no problem, proxmox also switches the virtual machines off etc.
But then I have to run apcupsd in proxmox.

Now I am wondering if I can also run apcupsd in hassio with the same usb connection, or are there other solutions?

Thanks in advance for thinking along and your advice.

1 Like

You can simply install apcupsd on your Proxmox node and configure it to be reachable over the network. Configure HASS to use that particular host/port and you’re all set.

I’ve been using it like this for about 2 years now and it’s working like a charm :slight_smile:

That sounds great!

I am going to try that !


It is working!!

Thank you!

Awesome, glad to hear you got it to work! :slight_smile:

Hello, sorry to ask…

Would you mind one of you @syphernl or @dzjr detail me the solution ?

I have a HassOS+hassio on a VM on a Proxmox and I just bought an APC UPS and I am new to UPS stuff.

I don’t know how to “configure apcupsd to be reachable over the network” and I don’t know how to “configure HASS to use that particular host/port”.

Thanks !

It’s actually pretty easy:

Run this on your Proxmox node:

sudo apt install apcupsd

Edit /etc/default/apcupsd and set ISCONFIGURED=yes

Start APCupsd if it is not running already
/etc/init.d/apcupsd start

Verify that it works with `apcaccess.

Follow the instructions on the apcupsd integration page. For HASSIO it seems there is an addon so this part should pretty easy.

1 Like

So simple is that ?

I read people telling not to install packages directly on proxmox system by fear to break it 'and indeed I break it when I tried to install some bluetooth drivers by compilation.

Does it mean I don’t need to make the USB port of the APC connection passtrough for Home Assistant VM and the addon will get it anyway ?

Thanks for the help !

Normally it wouldn’t be a good idea to install stuff directly on the host, I agree. But I consider apcupsd a crucial service for which I make an exception (just like a monitoring daemon for instance). The advantage of running apcupsd on the host itself is that it can gracefully shutdown your system when the battery power is low.

Another advantage is that you won’t need to do any usb passthroughs, simply point your HASS apcupsd configuration to the host and it should work.

1 Like

OK. I will follow your experience and I agree with your point.

“point HASS apcupsd configuration to the host” is a mystery phrase for me right now but I guess I will understand it while working on it.

I am getting through.

apcups.conf was wrong by default then, I didn’t see a lot of parameters with ‘apcaccess’.

I used this link to modify the conf file and this seems to be better :slight_smile:
ups_apc [Wiki ubuntu-fr] (ubuntu-fr.org)

I got this message while starting the service in syslog but I assume that’s not a problem :
apcupsd.service: Can’t open PID file /run/apcupsd.pid (yet?) after start: No such file or directory

Here some feedback !

As far as I can tell, I configured apcupsd directly on Proxmox node with NSIP = in the apcpupsd.conf file and wrote in configurations.yaml file as apcups integration page ask and with the proxmox node local IP adress under ‘apcupsd: host:’.

At this step, I have tried this without ever installing the APC UPS DAEMON unofficial addon - as asked by the integration page - because it seems to me that it would install the full apcupsd service in hassio - which I didn’t want (I will let proxmox alone stop the virtual and physical machines).

It seems as if APC informations are correctly monitored in the sensor entities created this way. So no need to install the APCUPS add-on if you only want to have APC reporting in Home Assistant when APS is installed elsewhere. So far so good.