API change on UpTime Robot service

Tags: #<Tag:0x00007f326ff1b1b8>

I have integrated uptimerobot in Home Assistant with success, but i now received the email at January 21, 2021:

[IMPORTANT]: The API version you are using is deprecated

Hello,
We’ve noticed you’re still using our deprecated APIv1 while APIv2 is already available. APIv1 is no longer supported, meaning bugs won’t be fixed and no new features will be added.
We recommend switching to the newer version, you can find the updated Documentation for APIv2 here: https://uptimerobot.com/api/
Let us know if you have questions or need any assistance.
Regards,
UptimeRobot Team

I received another at January 26, 2021:

[Important]: New API Features will be added
Hi,
on February 8th, 2021 we’ll add new features to our current APIv2 that may affect you:
New API features:

  • Allow using of a read-only access token to all “get*” endpoints
  • CORS headers are sent only for “get” endpoints* (for security reasons)
  • API key as a query string
    Let us know if you have any feedback or questions, thank you.
    Regards,
    UptimeRobot Team

Will Home Assistant be compatible? Has it already been updated?
Thanks for your great work.

Yes, I got the same email and for the time being have removed the uptime robot integration from my setup. Hopefully this will get updated at some point.

In fact, even mine no longer works, we’ll see what happens later.

The Home Assistant integration has never used V1 only V2 of their API

Great, but then why did the integration stop working?

yup testing on my end… it did not work

If that’s the case please open an issue and provide logs in that issue

It turns out they send the email to everybody, not just people who are using the V1 API still.
That being said, when I opened my UptimeRobot app (iOS) yesterday, it told me I had to update before I was able to use it, maybe they did change something on the backend that causes the integration to break, haven’t tried setting up in Home Assistant yet

EDIT: I’ve enabled the integration now, and it seems to work perfectly for me.

Yeah, I was in contact with them last week about that, they basically told me/us to ignore the email.

1 Like

Hey guy, I solved it, deleted the API key and re-entered it in Home Assistant, everything started working again. In fact, it had already happened to me some time ago, I had taken notes in the sensor.yaml configuration file. Thanks to all and good luck.

Hi guys, I newly setup uptimerobot for my sites.
I have generated the API key on uptimerobot.com and added the following to configuration.yaml as per the docs:

binary_sensor:
  - platform: uptimerobot
    api_key: YOUR_API_KEY

After restarting homeassistant, I am not able to find the sensors in Developer Tools > States
is there anything else I am missing?

You should look at the log for errors?

Are you sure you’re missing them? Mine is called binary_sensor.home_assistant. Not very obvious. You could try to type “uptime” in the attribute filter.