API error after update

I have been using node red to change the status of my Alarmo setup.

After updating to 11.0 I am getting an API error with this

Call-service error. value should be a string for dictionary value @ data['entity_id']

I can’t figure out how to fix this issue

That usually means the call service node is configured wrong, but if you don’t share your flow there is no way to tell.

everything was working find before the update

edit: I have also tried it with the alternate template box checked and unchecked

I don’t use this but first off the entity alarmo that’s it just one word? Looking at the docs the entity id may need to be in data, you could try leaving entity blank and use this in the data field

    "entity_id": "alarm_control_panel.alarmo",
    "code": 1234,
    "mode": "away"

I will try adding that and see if it works but when choosing it from the new drop down this is what it looks like

it seems as though not selecting the entity in the drop down but putting it in the data field worked

I have since encountered a similiar issue with my alarmo automations since the latest nodered update.

I’ve also had to remove it from the drop down and add it to the data field. Not sure why I’ve only encountered this issue with Alarmo.

The docs example automation shows the ‘entity_id’ in the data. Node red call service data usually mimics what you would use in an HA automation. I can’t say if it has changed recently or nodered is just catching up.

The recent updates to HA have been focused on tightening things up. Errors that used to be allowed to pass can now halt the system. Like errors caused by some sort of work around. Possibly due to a lack of functionality for example. As that functionality is added, then the work around then is no longer allowed to pass.