App not displaying HACS page

The companion app is fantastic and a great addition to HA. Thank you devs.

Up until recently, it did display the HACS page but not anymore. I have a Samsung Note9 with Android 10 and a RPi 4 running LineageOS 17.1 (Android 10) and neither will display the HACS page.

Is this common or am I doing something wrong?

Did you by chance remove the option from the side bar? Is hacs up to date? I don’t see the issue personally on any of my devices

The option is on the sidebar of both, and both are blank pages. HACS does show up on the local:8123 Web page.
Mysterious.

make sure android system webview is up to date

Yep, checked and up-to-date. I am a compulsive updater for everything. :blush:

I have noticed the same issue (OnePlus5, up to date)
The issue is only with the app, HACS will open properly in a web browser.

Same here on my Huawei Mate 10 pro on Android 10, all updates installed

Are you getting a white page? If so, it appears to be a caching issue. Clearing the cache from the app settings in Android (holding down on the HA icon and tapping “App info” goes there on my phone) fixed it for me.

2 Likes

Check your logs… and maybe restart again… I have had quite a few occasions where HACS disappears after an update and usually there would be a ton of errors in the log. A second restart usually fixed it on its own for me… also did you try on desktop to see if it’s an app only issue or all of HACS issue?

It is an app only problem. I uninstalled and re-installed the app on both devices and HACS now appears

I’ll do that next time if it happens again.

That fixed it for me too. Thanks for the tip