Appdaemon - Disconnected from Home Assistant, retrying in 5 seconds

running HA 0.95.4 on QNAP Docker ,
Install AppDaemon on a docker:

docker run --name=appdaemon -d -p 5050:5050 \
  --restart=always \
  -e HA_URL="https://192.168.1.112:8123" \
  -e DASH_URL="http://192.168.1.112:5050" \
  -v /share/AAA/appdaemon:/conf \
  -v /share/AAA/appdaemon:/certs \
  acockburn/appdaemon:latest 

HADashboard URL is accessible:

HADashboard

Welcome to HADashboard for Home Assistant.

The following Dashboards are available:
Hello

but its looks it can connect to HA ,
see log:

2019-07-21 22:06:13.819316 ERROR AppDaemon: Required attribute not set or obtainable from any plugin: latitude
2019-07-21 22:06:13.819587 ERROR AppDaemon: AppDaemon is terminating
2019-07-21 22:06:13.820416 ERROR AppDaemon: Required attribute not set or obtainable from any plugin: longitude
2019-07-21 22:06:13.821506 ERROR AppDaemon: AppDaemon is terminating
2019-07-21 22:06:13.823142 ERROR AppDaemon: Required attribute not set or obtainable from any plugin: elevation
2019-07-21 22:06:13.824164 ERROR AppDaemon: AppDaemon is terminating
2019-07-21 22:06:13.825270 ERROR AppDaemon: Required attribute not set or obtainable from any plugin: time_zone

appdaemon.yaml:

log:
  logfile: STDOUT
  errorfile: STDERR
appdaemon:
  threads: 10
  plugins:
    HASS:
      type: hass
      ha_url: https://192.168.1.112:8123
      latitude: 32.93
      longitude: 35.01
      elevation: 20
      time_zone: <define>
hadashboard:
  dash_url: http://192.168.1.112:5050

any suggestions?

Don’t specify them and it will use what you set in HA. If you want to override HA. Then this is the indentation:

log:
  logfile: STDOUT
  errorfile: STDERR
appdaemon:
  threads: 10
  plugins:
    HASS:
      type: hass
      ha_url: https://192.168.1.112:8123
  latitude: 32.93
  longitude: 35.01
  elevation: 20
  time_zone: <define>
hadashboard:
  dash_url: http://192.168.1.112:5050

This indentation is implied in the documentation.

https://appdaemon.readthedocs.io/en/stable/CONFIGURE.html

I’m guessing that you don’t have anything specified in HA and you’re placing the attributes in the wrong spots in AD.

I recommend adding these to HA and then removing them from the AD config.

Add them through the UI.

Thanks Petro,

Done:

I delete /appdaemon/conf dir the appdaemon.yaml
( the directory contain also apps dashboard and compiled directories)

in homeassitant/conf dir
set appdaemon.yaml as below:

appdaemon:
  threads: 10
  plugins:
    HASS:
      type: hass
      ha_url: https://192.168.1.112:8123
      latitude: 32.93
      longitude: 35.0
      elevation: 20
      time_zone: Asia/Jerusalem
hadashboard:
  dash_url: http://192.168.1.113:5050

didn’t work - same error .

Also tried setting /appdaemon/conf//appdaemon.yaml
as u suggested

log:
  logfile: STDOUT
  errorfile: STDERR
appdaemon:
  threads: 10
  plugins:
    HASS:
      type: hass
      ha_url: https://192.168.1.112:8123
  latitude: 32.93
  longitude: 35.01
  elevation: 20
  time_zone: Asia/Jerusalem
hadashboard:
  dash_url: http://192.168.1.112:5050

log

2019-07-22 20:32:27.450946 INFO AppDaemon Version 3.0.5 starting
2019-07-22 20:32:27.451379 INFO Configuration read from: /conf/appdaemon.yaml
2019-07-22 20:32:27.509290 INFO AppDaemon: Starting Apps
2019-07-22 20:32:27.515237 INFO AppDaemon: Loading Plugin HASS using class HassPlugin from module hassplugin
2019-07-22 20:32:27.863097 INFO AppDaemon: HASS: HASS Plugin Initializing
2019-07-22 20:32:27.863780 INFO AppDaemon: HASS: HASS Plugin initialization complete
2019-07-22 20:32:27.864417 INFO Starting Dashboards
2019-07-22 20:32:27.877246 INFO API is disabled
2019-07-22 20:32:27.924063 WARNING AppDaemon: HASS: Disconnected from Home Assistant, retrying in 5 seconds

Lost :frowning:

no…

which would be a config like this

appdaemon:
  threads: 10
  plugins:
    HASS:
      type: hass
      ha_url: https://192.168.1.112:8123
hadashboard:
  dash_url: http://192.168.1.113:5050

Anyways, I don’t think this is causing your issues. It would be best if you moved this post over to the third party integrations / appdaemon for follow up.

Also, side note, your hass dash ip is wrong based on your setup. you use 112 in the docker setup yet call out 113 in the configuration. Still not going to solve the disconnection issue though.