AppDaemon, HACS & app_dir confusion

New to AppDaemon. I successfully installed it in docker. With public FQDN of Hass that is.
I can’t get it to work with the internal hostname and setting verify_cert to false, no clue what I’m doing wrong there. I would still prefer the internal host though.

However, my main question is about the app_dir.
In the AD dashboard I can see the Hello_World in the apps tab.
I also installed ControllerX via HACS, but that isn’t showing up there. Should it show up in the AppDaemon dashboard for it to work?
HACS is installing this in homeassistant/config/appdaemon/apps
While AppDaemon is using appdaemon/conf/apps

Should I point the app_dir option the the folder used by HACS? Is there a way to keep using both folders?

Thanks!!

You can move your appdeamon config folder to homeassistant/config/appdaemon/ and then change the volume mapping in the docker file. Are you also running HA in docker?

Regarding the internal hostname issue, please post your appdaemon.yaml file so we can have a look. Mask out any secrets.

1 Like

Thanks very much!

Moving the config folder worked (although the hello world app is not created anymore then, I assume since I already had a apps.yaml in the folder :slight_smile: )

The hostname issue I’ll come back to later.

So the internal hostname issue.

I run Hass as docker as well, indeed, with network = host.
I run AppDaemon as follows:

docker run --name=appdaemon -d -p 5050:5050 \
  --restart=always \
  -e HA_URL="https://<internal_hostname.internal_domain>:8123" \
  -e TOKEN="<long lived token>" \
  -e DASH_URL="http://$HOSTNAME:5050" \
  -v /volume1/docker/homeassistant/config/appdaemon:/conf \
  --memory=512m \
  acockburn/appdaemon:latest

My AppDaemon config looks as follows:

appdaemon:
  plugins:
    HASS:
      type: hass
      ha_url: https://<internal_hostname.internal_domain>:8123
      cert_path: <path to external domain certificate>
      cert_verify: false
      token: <long lived token>
  time_zone: <time zone>
  latitude: <lat>
  longitude: <long>
  elevation: <elev>
http:
  url: http://<hostname>:5050
  password: <password>
admin:
api:
hadashboard:

Does it work if you use the internal ip instead of the internal hostname?

No, same result :frowning:

Can you post the http: section of your HA configuration.yaml?

And the auth_providers section. You should probably add your appdaemon ip to the trusted_network section. This is how I have set it up.

Thanks for your quick response everytime and efforts to help!!

My http: looks like this:

http:
  ssl_certificate: <certificate path>fullchain.pem
  ssl_key: <privkey path>/privkey.pem