Appdaemon REST API Troubleshooting

Hello, I at one point had registered endpoints in Appdaemon working consistently for months and then they somehow broke. I think the main change was an Appdaemon upgrade (sorry I don’t know what versions but it was July 2023 I believe - I don’t auto upgrade though). I can confirm the endpoints are being registered still with a log, but I can’t hit them like I used to.

Anyway, I’m mostly curious if there’d be any simple sanity checks / troubleshooting options I could try. For instance, it seems like a good first step to simply successfully hit my endpoint from within the Appdaemon docker container, yet I can’t even accomplish that.

Some things I’ve tried: setting both api_port and ad_port within appdaemon.yaml. Setting those to both 5050 and 5051 (and curl’ing for the endpoint at those ports). When I had the endpoints working, I don’t believe I had any such configuration in appdaemon.yaml though.

One specific question would be, on docker ps -a should I see that api_port listed in the PORTS column for my appdaemon container? I only ever see 5050, but never 5051 when I’ve tried that configuration.

Thanks in advance! Happy to post any output that may be helpful.

FWIW I did a fresh install a month or so ago to get off the Raspberry Pi I was running on and the Appdaemon rest API works like a charm again. Not sure what happened exactly, but I must have somehow gotten into a bad state in my old setup and a fresh install got me out of that.