AppDaemon won't start anymore

yesterday we’ve had a power outtage and later that day the power came back, but since then, AppDaemon won’t start anymore.

If I click “Start”, the button turns red and that’s it. The Log window underneath is blank and even when pressing “Reload”, it stays blank.

Since I’m using Ubuntu Server, I typed:
service docker status
This returned following:

Sep 10 13:55:57 oliver-nuc dockerd[1178]: time="2019-09-10T13:55:57.681558656Z" level=warning msg="Failed to allocate and map port 5050-5050: Error starting userland proxy: listen tcp bind: address already in use"
Sep 10 13:55:57 oliver-nuc dockerd[1178]: time="2019-09-10T13:55:57.777698726Z" level=warning msg="688e83c7e255bca0751eac5b5d6f1f2d792da6c8d0418e2e46aed64f386ad7c0 cleanup: failed to unmount IPC: umount /var/lib/docker/containers/688e83c7e255bca0751eac5b5d6f1f2d792da6c8d0418e2e46aed64f386ad7c0/mounts/shm, flags: 0x2: no such file or directory"
Sep 10 13:55:57 oliver-nuc dockerd[1178]: time="2019-09-10T13:55:57.811504750Z" level=error msg="688e83c7e255bca0751eac5b5d6f1f2d792da6c8d0418e2e46aed64f386ad7c0 cleanup: failed to delete container from containerd: no such container"
Sep 10 13:55:57 oliver-nuc dockerd[1178]: time="2019-09-10T13:55:57.811590545Z" level=error msg="Handler for POST /v1.39/containers/688e83c7e255bca0751eac5b5d6f1f2d792da6c8d0418e2e46aed64f386ad7c0/start returned error: driver failed programming external connectivity on endpoint addon_a0d7b954_appdaemon3 (df18dacb31cb922dc0f235200ebfff11bb9ac290aa3ecd596085626711d86b46): Error starting userland proxy: listen tcp bind: address already in use"

Since I’m familiar with the error “bind: address already in use”, I searched for anything already running on port 5050 with:
lsof -i :5050
But unfortunately, there’s nothing open on this port.

I don’t know what to do.

Any help is greatly appreciated!

EDIT: After the failed staring attempt, “java” is now running on port 5050, but AppDaemon still isn’t. Killing the process (and thus freeing the port) and then trying to start AppDaemon again, returns the same error as above.

EDIT2: It seems that “java” begins running on port 5050 after a couple of seconds on it’s own, and thus, blocking the port for AppDaemon, I think. However, I don’t remember putting anything on that port.

EDIT3: Yes, if I “kill -9” the port and then immediately start AppDaemon, it starts successfully. Now I’m still not sure what “java” is or should be.

I’ve discovered the culprit!

It’s Traccar. It uses port 5050 for some reason (mmcc).

When starting AppDaemon before Traccar, Traccar complains:
2019-09-10 11:33:26 WARN: Port 5050 is disabled due to conflict