Appdaemon wont start properly on Synology Docker

Tags: #<Tag:0x00007f32704e1f70> #<Tag:0x00007f32704e1d40>

Hi,

I cannot get appdaemon to run.

Log below.

|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.128028 INFO AppDeamon Exited|
|---|---|---|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.127563 WARNING ------------------------------------------------------------|
|2019-09-08 02:41:21|stdout||
|2019-09-08 02:41:21|stdout|TypeError: a bytes-like object is required, not 'str'|
|2019-09-08 02:41:21|stdout|    dash_net = url.netloc.split(":")|
|2019-09-08 02:41:21|stdout|  File "/usr/local/lib/python3.6/site-packages/appdaemon/rundash.py", line 130, in __init__|
|2019-09-08 02:41:21|stdout|    self.rundash = rundash.RunDash(self.AD, loop, self.logger, self.access, **hadashboard)|
|2019-09-08 02:41:21|stdout|  File "/usr/local/lib/python3.6/site-packages/appdaemon/admain.py", line 82, in run|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.127030 WARNING Traceback (most recent call last):|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.124824 WARNING ------------------------------------------------------------|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.124443 WARNING Unexpected error during run()|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.123828 WARNING ------------------------------------------------------------|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.123006 INFO Starting Dashboards|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.122202 INFO AppDaemon: HASS: HASS Plugin initialization complete|
|2019-09-08 02:41:21|stdout|2019-09-08 02:41:21.121368 INFO AppDaemon: HASS: HASS Plugin Initializing|
|2019-09-08 02:41:20|stdout|2019-09-08 02:41:20.606713 INFO AppDaemon: Loading Plugin HASS using class HassPlugin from module hassplugin|
|2019-09-08 02:41:20|stdout|2019-09-08 02:41:20.599017 INFO AppDaemon: Starting Apps|
|2019-09-08 02:41:20|stdout|2019-09-08 02:41:20.568106 INFO Configuration read from: /conf/appdaemon.yaml|
|2019-09-08 02:41:20|stdout|2019-09-08 02:41:20.567534 INFO AppDaemon Version 3.0.5 starting|

What commandline did you use?

Installed via the docker package on synology Package Centre.

Also tried ssh with putty.