Apple HomePod not discovered or visible

Hi, I have setup home asst on Raspberry pi 3+ recently. it is generally working well, however when I 1st set it up, it discovered my 3 HomePods and installed the integration & the devices seamlessly
one I removed -an original device, leaving 2 minis installed - using delete from the R hand dropdown menu.
I have recently tried to add it back

it doesn’t recognise the name constantly, but the wifi address works.

I get the message
Confirm adding Apple TV
You are about to add Roaming of type HomePod to Home Assistant
and then

Apple TV

Re-authentication was successful

However the device doesn’t appear.

resetting one of the HomePod minis causes it to be discovered immediately.

I have tried resetting that HomePod, changing its location and removing the other HomePods & the apple integration, but still get the same response.

I have not found any similar problems in the posts.

the logs showed a HomePod mini not located when I turned it off, but no other refs to HomePod.

I wondered if the original installation has left a config for that HomePod somewhere, but I can’t locate anything in HA code on Github to suggest where to look, & no idea if that’s the problem - just a guess.

any advice would be greatly appreciated.

  • Core2023.11.3
  • Supervisor2023.11.3
  • Operating System11.1
  • Frontend20231030.2

Seán

I have exactly the same issue with 1 of my HomePod Mini’s and an Apple TV.
Have you figured out something already?

Finally!
It’s an integration, not a device. have a look at the R hand menu inverted triangle of 3 lines. see if anything I signed or disabled there
good luck