Apple TV Integration - tvOS 15 Beta

It is not yet but will be.

1 Like

How do you launch apps? I see pyatv has the functionality but I’m unsure about launching from HA. And would you mind posting your yaml for the remote control card?

Hi,

I wil not be able to pair. Did someone now how to fix this?

Not supported in Home Assistant yet.

You need to go to Settings->AirPlay on your Apple TV and make sure everyone on the same network are allowed to connect.

Thanks, it works.
I had it on “everyone”

I’m still having problems setting up the integration for any of my Appletv devices.
Only one shows up to be configured, but, if I tell HA to configure another instance it finds the other two on my network. i can start the integration process and i get a PIN code on the screen, but, when I enter it into HA I get the aborted message and it tells me to try again.

tvOS is 15.1.1
HA is 2021.11.5
the devices are on the same network and airplay/homekit is set to allow access to same network & nearby.

am I missing something obvious? i’ve tried restarting HA and the AppleTV devices several times.

Yeah sorry, found that later after digging through your git requests/issues.

I have a samsung tv and sound bar so I can’t control volume with the apple remote. So instead I created a universal media player template and combined the Apple TV remote functionality and the Samsung TV media player volume. I’m displaying them with mini-media-player.

Here’s the code for the card if anyone is interested

mini player

yaml for media_player

media_player:
  - platform: universal
    name: Living Room TV
    children:
      - media_player.living_room
      - media_player.samsung_tv
    commands:
      volume_up:
        service: media_player.volume_up
        data:
          entity_id: media_player.samsung_tv
      volume_down:
        service: media_player.volume_down
        data:
          entity_id: media_player.samsung_tv
      volume_mute:
        service: media_player.volume_mute
        data:
          entity_id: media_player.samsung_tv
          is_volume_muted: true
    attributes:
      is_volume_muted: true
      source_list: media_player.samsung_tv|source_list
    device_class: tv

card:

type: custom:mini-media-player
name: Living Room
icon: mdi:television
group: false
source: full
sound_mode: full
scale: '1'
volume_stateless: true
hide:
  volume: false
  power: false
  controls: false
  jump: false
  runtime: false
  runtime_remaining: true
  power_state: false
shortcuts:
  hide_when_off: true
  columns: 3
  buttons:
    - icon: mdi:television
      type: service
      id: remote.send_command
      data:
        command: home
        entity_id: remote.living_room
    - icon: mdi:arrow-up
      type: service
      id: remote.send_command
      data:
        command: up
        entity_id: remote.living_room
    - icon: mdi:less-than
      type: service
      id: remote.send_command
      data:
        command: menu
        entity_id: remote.living_room
    - icon: mdi:arrow-left
      type: service
      id: remote.send_command
      data:
        command: left
        entity_id: remote.living_room
    - icon: mdi:arrow-down
      type: service
      id: remote.send_command
      data:
        command: down
        entity_id: remote.living_room
    - icon: mdi:arrow-right
      type: service
      id: remote.send_command
      data:
        command: right
        entity_id: remote.living_room
    - icon: mdi:checkbox-blank-outline
      type: service
      id: remote.send_command
      data:
        command: select
        entity_id: remote.living_room
entity: media_player.living_room_tv
artwork: material

3 Likes

I’m having exactly the same issue, but with just 1 Apple TV. ‘Aborted’ every time I enter the PIN.

have you found any fix for this yet, by chance?

To help me out, please open issues at the pyatv project and include logs. That way I can try to help you out. Make sure to look at open issues in case someone else already reported the issues. I will most likely forget and lose track of issues reported in this thread.

absolutely - so, i’ll apologize in advance for not knowing, but, would that be done here?

and, would the logs you need be listed there too? i’m just not certain what logs to include.

thank you.

thnx! it work tvOS15.1

@postlund Thank you so much for developing this add on. I have managed to connect my HomePod Mini and I’m able to play music through the service media_player.media_play. So far so good!

However, when I try to use media_player.play_media to select a specific mp3 file and send it to the HomePod the file doesn’t play and the log shows this error:

This error originated from a custom integration.

Logger: custom_components.apple_tv.media_player
Source: custom_components/apple_tv/media_player.py:266
Integration: Apple TV 
First occurred: 10:00:43 (1 occurrences) 
Last logged: 10:00:43

Media streaming is not possible with current configuration

Any thoughts on how I can resolve this? Thank you.

It is currently only possible to play local files, not from external sources like HTTP. I’m hoping to release experimental support for HTTP(S) the upcoming week though.

1 Like

Thank you, that was exactly what I needed to know. I had placed a sound file into the www folder and tried to call it via http. When I placed the file in /media and called it from there it worked!

I just pushed an update to the component that should support streaming from HTTP(S). It’s experimental and probably not very stable, but feel free to give it a try.

After this update 2.0.0 i cannot use integation anymore. old devices show ( from last version), but when try to add new from integration - apple tv → Screenshot 2021-12-06 145152

Unfortunately some changes requires code that are only in the next release, so please roll back to previous version and wait until it released this weekend or join the beta channel.

Hey to all,
I’m quite new to HACS but I finally managed to install it in HA.
But I do not find the repository of this Beta-Apple TV Integration - do I do something wrong? Do I have to activate something to see beta-versions? I did not see anything like that…

Any help would be highly appreciated!

Best regards
Joerg