Apple TV "no devices found" despite using an IP address which is reachable from HA

I’m hoping someone has an easy answer to this before I start digging in to source code. I’m trying to add an Apple TV to Home Assistant directly via the static IP address assigned by my router. However, HA always tells me that “no devices were found on the network.”

I have checked the following:

  • I can ping the ATV IP from HA
  • Bonjour is enabled and the ATV is discoverable on the network by other devices
  • I can also control the ATV from my iPhone on the same network using the Remote app

FWIW, I previously had an ATV setup with HA a couple years ago. This is a new (latest gen) ATV with HA v2021.09

What version of Home Assistant are you running? I had to upgrade to a current version in order to add AppleTV’s to my HA system. Also, tvOS v15 is not supported at this time, IIRC. Not sure if the dev has figured out a solution for tvOS v15 yet.


AFAICT, tvOS 15 is still in beta (at least until WWDC next week :wink: ). This is a latest-gen (2021, 4k v2) ATV, but I have not opted into the beta OS program.

1 Like

Incidentally, I only want the integration in order to trigger automations based upon the on/off state of the ATV. I’d be happy with any other solution that allowed me to trigger on this state, even if it required some additional work.

In fact, the problem I’m trying to work around is that I cannot use the built in support (Siri Remote) for turning on/off the TV/receiver which is connected to the ATV. This is because I have a HDMI audio extractor between the two devices, which appears to break HDMI-CEC.

Do you have AirPlay enabled in the AppleTV’s Settings? Just a guess…

Yep. I also tried setting access to Everyone (instead of just “on same network”).

1 Like

Apple TV dont show on/off state in HA. Only Idle and play,pause etc. Sleep and awake both shown as iddle. I use hdmi for that purpose, but since you cant use hdmi the next best thing i used to do is use a smart plug with a power sensor which work with HA and use power sensor for automation.

every other media device is just fine accept the silly Apple TV

1 Like

Ah, that’s good to know — thanks. I had considered the smart plug approach but I worried that it would be error-prone (the power usage might be temporarily low while on, and even when “off” it will not be zero since the ATV still responds to the remote control). Instead, I’m looking at using this HDMI-CEC to USB adapter. In theory, it should let me read the CEC signals extracted from the HDMI cable…

I didnt get what hardware you HA is on. If its a raspberry you also run into difficulty since HA drop support for HDMI CEC on raspberry hardware. I use this plug in to run a CEC server on the raspberry via TCP. I have no idea how the inner working of that but you might want to give it ago see if this TCP version can punch through the audio extractor. I also interested to know.

Has anyone got to the bottom of this, I have exactly the same issue, but there was no real answer?
Here are my version numbers:
Home Assistant: 2023.1.7
Supervisor: 2023.01.1
Operating System (HAOSS): 9.5
HA IP Address: 172.x.y.102 (The x & y is the same across all devices)
Apple TV 4K-128GB - Wireless
Apple TV OS: 16.3
Apple TV Network Access: Everyone
Apple TV Network IP: 172.x.y.40 (Static DHCP)
I am trying the Apple TV intergration from Settings->Integrations->Apple->Apple TV.

Any help would be appreciated.


1 Like

Same setup (versions, config, same network), only using the container install. Same problem.

1 Like

Same issue, HA will not let me add ATV, searched and searched no resolution.

I am new to HA I utilize HomeSeer but there is no ATV plugin for HomeSeer.

I am running HA on a Synology NAS if that makes a difference, I have 3 ATV but cannot “see” any of them. I was able to get a Plex integration running and communicating to HS so I know HA works just wanted to add ATV.



Same issue here. HASS v2023.2

1 Like

I managed to fix all of the broadcast issues including this one by simply moving to Linux docker container installation.
The problem is that Windows/MacOS docker doesn’t really support --net=host mode which is meant to use host’s (machine’s) network - all multicast traffic is broken in this case.