Apple Watch allow (Shortcut name) to access "(null)"?

Hey bwelle,
I have the same problem with iOS 16 and WatchOS 9 - all my HA Shortcuts stopped working via Siri/Voice and they only work if you press them via the shortcut complication…

other shortcuts work fine via voice though, i have deleted and repaired my watch at least a dozen times with no luck…

if you find a fix, let me please know

i just got it working… i have no idea what ive just done
i just tested all my other shortcuts via voice and miraculously the HA shortcuts work via siri again…

Yes, same here I should have reported back. I think it was a combination reboot of home assistant, the watch and my iPhone. It started working gall of a sudden. I still think the whole shortcut/siri with HA and the watch are a little sketchy. Right now, I am having fun with complications!

After researching this topic, I found that if you remove the Home Assistant app from the watch and rerun the shortcuts, no prompt appears. If you’re dependent on the watch app for complications, obviously this is not going to help. For me, I am more interested in speaking and having something just work. One caveat: the shortcut app opens on my watch after the event has fired. A small annoyance but I don’t have to interact with the shortcut app. And I have disabled the “Show when run” option. I also added “Dismiss Siri and Continue” followed by “Stop this shortcut” and it seems to tidy things up.

Hope this helps someone.


Big thanks. I wish I could keep the app on the Apple Watch. But this will do the job for now :+1::+1: