Apple Watch allow (Shortcut name) to access "(null)"?

I have my shortcuts setup and they work fine on the iphone manually executing them or using Siri, but when I try to have siri do this from the apple watch I get this message allow “turn off office” to access “(null)”? I click allow and get a error could not run action. Any ideas?

I’m running 8.1 on my watch and IOS 15.0.2 on my phone.

I experience the exact same thing. Hopefully somebody will know what’s going on.

I’m having the same issue since iOS 15/watchOS 8. Still happening on iOS 15.1/watchOS 8.1 and the latest HA app version. I’ve checked the privacy settings in the shortcut, it already had the permission to use Home Assistant.


I read a discussion over in the Apple support forums where other users were having this problem not specific to Home Assistant.

I was having issues with shortcuts working in general, with my Apple Watch. But after I upgraded my phone to IOS 15 and the watch to 8.0, I am getting the exact same message. If I click(or speak) “Allow”, the shortcut runs and actually successfully calls my script and it works. Even though I get another message that said “something went wrong”. This is very disappointing because I have put some effort into these scripts and it is a pain to have to answer another question to get a script to run. I use mine to open and close my garage as well as arm/disarm my alarm system. I have also seen plenty of messages on readit and apple and everyone is complaining about this, since October.

Since the new watchOS (8.4) / iOS(15.3) updates “(null)” has been replaced with “Home Assistant”. Unfortunately this didn’t solve the issue. I tried everything: resetting the shortcuts privacy permissions, re-adding it to the Apple Watch, … But the issue still persists. Am I doing something wrong? Is it working again except for me?

I have IOS 15.2.1 and Apple Watch 8.4. I will be upgrading my IOS to 15.3 tonight. But as it stands right now, technically my short cut is working from my watch. But…the annoying thing is, it just does not execute the shortcut(service), it askes that silly question about allowing the shortcut. "Allow (my shortcuts name) to access home assistant? Allow or Dont Allow. When I tell my siri watch to “Arm Home”, I want it to arm home, I dont want to have to answer another question. But you do get the shortcut to work correct? At least mine are working, there is just that second question that seems strange to me.

I did upgrade my phone to IOS 15.3 and the shortcut STILL prompts me for the “Allow or don’t allow” message. Annoying, seems to be some sort of security setting. I wish I knew where it was and how to allow Home Assistant companion app to just execute the shortcut when I tell siri to execute it.

Same issue here, I tried to go to the privacy settings of the shortcut and disable then re-enabled home assistance access to the shortcut, but the issue remains…
I found a workaround though, by sharing home assistance entities to HomeKit and then trigger the entity from HomeKit instead of a hassio service call.
But I don’t like this workaround, so I’m still in interested in a solution here if anyone has one :slight_smile:

Hi, I’ve opened an issue regarding this problem over a year ago:
Still no look as of right now on my end aswell.

Is there a HomeKit Hub involved, right?


Just for the record: iOS 15.4.1 and watchOS 8.5.1 and Apple didn’t fixed the bug yet…

1 Like

yup…still works fine from the phone but when trying to voice control from the app…still getting the allow/dont allow options

Any update on this topic?

Updated to IOS 16, and apple watch 9.0 the other day. Disappointed to find out that now my shortcuts dont work at all. At least before, I was getting that anoyng message to “allow” or “dont allow” and the shortcut work work… Please if anyone has any suggestions. I cant be the only person that want to command HA from their apple watch. Is this an apple issue, or a home assistant companion app issue?

just tested and surprised to see mine work, albeit it with the annoying prompt of “allow” or “don’t allow”

Shame this hasn’t been sorted yet but as I have no idea wh==hat has caused it or how hard it is to fix, it is what it is

Thanks that is good to know, so I must have something to clean up. I at least want to get it back to that annoying “allow or don’t allow” message. Right now, it just tells me…“oh oh, please try again, something went wrong”. Just to clarify, you have ios 16 and watch OS 9?

I do indeed…in fairness I use the watch actions from the complication most of the time anyway so the voice issue isn’t as much of an issue as it could be…but would certainly be nice to have

Got it, thanks. I think I can convert. the only thing I really like the voice for, is if I am driving in my car, I can tell siri(apple watch) to open my garage door. My phone is almost always in my pocket, so it is so convenient to talk to my watch hands free. But I found a watch face that I can have 6 complications which is awesome. And I have already found that it is easy to set a complication off by mistake, so having the “Allow or don’t allow” makes sense. It is still 2 taps vs zero and I have to take my eyes off the road, but what choice do I have?