Apple Watch complication, can’t get it to show on watch

Apple Watch complications

So I’m attempting an HA Apple Watch complication, and everything seems to be working as pictured here HA - Album on Imgur

I have the Modular watch face and I’m wanting this complication to be the middle one, the large one.

It doesn’t come up on my watch when I save it, it only says placeholder as pic here Watch - Album on Imgur

Cou anyone help? Once it’s working I’ll then chop and change sensors to see which one I like.

Also can you put things order than sensors in the complication? Like input Boolean’s etc?

Can you try launching the Home Assistant app on your watch to try and get it to sync? Nothing jumps out at me as being obviously incorrect, though.

You can put whatever text you want in the complication, as long as it fits in the field.

I’ve already tried that, when I clicked save I had it open on my watch :thinking: I’d heard maybe the watch complications were down​:man_shrugging:t3:

So say if I wanted to put iPhone, iPad or Mac in front of the battery level soo I know which device it is would I just type iPhone then the string of code?

Same issue here, tried force quitting both phone and watch app, restarting both phone and watch, forcing sync, adding more complications, downgrading from TestFlight bets to app store version, uninstalling/reinstalling watch app.

Same problem here - created several complications for several different faces but all I see in the watch app is Placeholder. All apps and iOS are up to date. Any ideas to try?

Just found this other thread that answers my questions - bottom line: Apple has deprecated some of the complications.

Excellent example video referred in that thread: