Apple Watch complications and widget, help needed. How to start?

I know this post was a while ago. But I am wondering if you ever got your complications working on your Apple Watch? I have set up my complication in the home assistant companion app on my iPhone and it seems to be working just fine. But like you, all I get to show up on my watch is “place holder” for home assitant when trying to add a complication to my watch face. Very frustrating.

1 Like

Hi I have this problem too. All I have is “Place Holder”

I have the same problem. See attached screenshots.


Is there a way to make a complication color graded, for example a temperature circle?

I solved that by activating “airplane mode” on my iPhone, waiting for a short time, and then deativating “airplane mode” again. Perhaps close Watch App and HomeAssistant App while “airplane mode” is active.

Afterwards the new complications were visible in the Watch App.

1 Like

I tried now several times to sync but my complications created in Home Assistant app never appears on my watch.
Seems this is maybe not working correctly with iOS 16 and also latest WatchOS.
Anyone has a reliable way how to get this working?
In the app it shows error while updating.
(Sync of actions works btw. perfectly and instantly)

2 Likes

Yes its broken since WatchOS 9. Complications in the Companion app are not syncing anymore with the Apple Watch, they are just not available anymore on your watch.

even on watchos 9?
i have just icon and “alternate text” in home assistant, and there is no compilations i’ve created.

Watch os 9 here and no complications.

Hi all. With WatchOS 9, a number of complications are no longer supported/working in the Home Assistant app. Apple has grouped these into their online guidance as ‘Legacy’ and so assume something has changed and the Home Assistant app needs to catch up and either update/remove.

I’ve put together an overview video here (Home Assistant and Apple Watch - Actions and Complications Guide (iOS 9) - YouTube) which includes an example for each complication type that is currently working. For those that are not working, you will just get a “Placeholder” text.

Hope this helps!

1 Like

That seems all to be working. In YouTube you write iOS 9 which is confusing.
Do you mean watchOS 9?
And which iOS Version then? Because with iOS 16 I can‘t reproduce that.

Thanks for the feedback. Yes, it should be watchOS 9 and I’m also using iOS 16 too in the demo. I’ve found it takes a few minutes to replicate the complications from the Home Assistant app to be visible in the Watch App. A few other things to try out and consider:

  • Correct watch face for template: Make sure that the complication template type is supported in the selected watch face and also those that are still compatible (e.g. the Graphic Circular, Graphic Corner, Graphic Rectangular and Modular Large).
  • Save the Companion App changes: Make sure you save and click done in the companion app
  • Wait for visibility: Sometimes I have had to wait a while or add/remove existing complications until the new ones are visible. Not sure what is the best option, but they do appear after some time. It shouldn’t take more than a few minutes.

IOS-Actions on AppleWatch 5

A long time ago it was the case that IOS actions could also be carried out without connecting the Apple Watch to the cell phone.
Unfortunately, this hasn’t worked for a long time. Seems to have been lost with some update.
Is it perhaps the case that you have to make some setting so that it works again?

Home Assistant on RPi4B with SSD
HA 2022.10.4
SV 2022.10.0
OS 9.2

I’d recommend creating a new thread for that question because this thread is about Apple Watch complications, not actions.

I don’t use Apple Watch actions myself, so don’t know how they work. I did (just now) try using an action on my watch with my phone turned off and got the same result as you (it didn’t work).

Hi Matt,
I have WatchOS 9.1 and iOS 16.1.1 installed. However, this is what I see on the Apple Watch setup page.

I have created a simple circular complication. Yet it does not appear. Any idea what’s wrong?