📳 Appliance Notifications & Actions - Washing Machine - Clothes Dryer - Dish Washer - ETC

Hi @Blacky. :raising_hand_man:

Today the same problem occurs again. Start notification works, end notification not and I don’t know whats wrong. :frowning:
In trace it stopped again here:

alias: Wait until appliance has finished
wait_for_trigger:
  platform: numeric_state
  entity_id: sensor.waschmaschine_power
  below: 2
  for:
    minutes: 1

And this is my YAML:

alias: Waschmaschine
description: ""
use_blueprint:
  path: Blackshome/appliance-notifications.yaml
  input:
    power_sensor: sensor.waschmaschine_power
    include_start_notify: enable_start_notify_options
    start_notify_device:
      - 6152c3d6a15cd34151a87fd05c860dd2
      - c151d1afef6e8ecd0181ba0f30c1fcba
    include_end_notify: enable_end_notify_options
    end_notify_device:
      - 6152c3d6a15cd34151a87fd05c860dd2
      - c151d1afef6e8ecd0181ba0f30c1fcba
    start_title: Waschmaschine
    end_appliance_power: 2
    start_message: Waschmaschine läuft
    end_message_title: Waschmaschine
    end_message: Waschmaschine fertig
    include_power_tracking: disable_power_tracking
    end_time_delay: 1

This is the end phase of my washing machine:

Do you have any idea what I’m doing wrong?

Cheers

@viruz

We know the blueprint works as it runs everyday here in fact it is running now for me. You also seen it work, you know your settings work so you should be all good there :wink: :+1:

So it has to be something happening in your HA :thinking:

Things that will stop it at that point are;

  1. HA restart
  2. Edit the automation when running.

Maybe this happened while it was running.

Hope this helps you.

Blacky :smiley:

Thanks @Blacky and sorry for the inconvenience. I really don’t know what’s the problem. The next washing machine worked as expected. The same as the last time I wrote here. :man_shrugging:t2:
Wish you a nice weekend. :blush:

@viruz

All good no problem :smiley:

I had 3 loads of washing yesterday and it worked every time… good thing you have seen it work so that helps.

I have tested your last YAML you posted of the automation (copy / paste). It is a very basic set up. I changed the power sensor and added my device and set the delay time to 0.1 to speed up the test. Worked first time, so you YAML is good and works :+1:

Try this test:

  1. Get another appliance that has high wattage like hair dryer, heater, kettle etc. Plug it into the power sensor.
  2. You can adjust the time delays for start and end to 0.1 to speed things up if you like.
  3. Turn it ON see if you get the start message.
  4. Turn it OFF see if you get the end message.

If this fails and you don’t have another power sensor to test with then you can use a temp sensor as it works of a numeric state. Just adjust the watts to suit the temp range your working in.

Let us know how you go.

Blacky :smiley:

1 Like

It is just to know how long the machine ran. If it could be implemented in the same way as the energy tracking it would be nice. Or even with less effort as no data needs to be pulled from an energy meter etc. Maybe this can be fully included into the blueprint without the need of creating helpers etc? Just a an checkbox “Enable run time tracking”?

@seblor

Okay I will put it on the list of suggestions.

Blacky :smiley:

Is it necessary to have the automation trigger properly to test a custom notification that includes a power consumption template? As I read this YAML after pasting it I’m thinking the answer is yes. My guess is that the variables aren’t set if the whole blueprint doesn’t run.

service: notify.mobile_app_x
metadata: {}
data:
  title: Washing Machine
  message: >
    Yippee the washing machine is finished! {% set kwh =
    states(end_power_consumption) | float - states(start_power_consumption) |
    float %} {{'\n'}}Consumption {{kwh | round(2) }} kWh {% set cost =
    (states(end_power_consumption) | float - states(start_power_consumption) |
    float) * (states(cost_per_kwh) | float) %} {{'\n'}}Approx Cost ${{cost |
    round(2) }}
  data:
    tag: washer
    notification_icon: mdi:washing-machine
    visibility: public

@Cake1468

It would be nice to have your full YAML not just a snippet so I can see what is happening.

Looks like you have a custom action… not sure if it is the start or the end custom action. If you would like to do a custom action with power it must be an end custom action. For power to work you must fill out all power tracking options. You must enable one option. If you are just using custom actions then you just enable the one as shown below. Once you do all that you should get the information your after in your custom action.

Hope this helps.

Blacky :smiley:

It’s all good. That was a custom end action.

I was wondering if it’s possible test it without having the whole automation/blueprint triggered by the power sensor as I had an error when I hit “run” on the custom action. I didn’t find a note about testing in the instruction posts, but could’ve missed it.

In the end, a run cycle and it notified as I hoped. :tada: I just needed to be patient and let it run it’s course.

Blacky, I’ve constantly been impressed by your blueprint first, then your documentation, and finally your support. It truly is above and beyond. Thank you for all that you!

Yeah, when you hit run it will do the start actions not the end as it waits for the power to drop below so you need to actually run a real test using the actual trigger.

Good to know you are up and running :+1:

Again thanks for you kind words.

Enjoy

Blacky :smiley:

Great blueprint with many options covered. A couple of enhancement suggestions would be the ability to report how long the device was on as part of the notification. Also the ability to use the Power Used and Cost of Wash in the optional Custom Actions - perhaps populating them to number variables?

@MrEcosse

Thanks :+1:

This suggestion keeps coming up… stay tuned.

You can do this by filling in the power information… see 4 to 2 post above.

Blacky :smiley:

Hi @Blacky ,
since dishwasches hat this stupid behavior of 2 peaks (at start and somehere in middle) and then end. Maybe it would be an option for this automation. Count Powerpeaks X for 1 cycle… somethink like that. maybe with powerpeak range ex. 500-700W

@Grandman

Have you looked at using the “Running - Dead Zone”. If you look at your cycle and work out your dips (not the peaks) and what time the dips are then set the running dead zone past that time so it will ignore your dips.

If you are unsure maybe post your graph of a cycle and I may be able to help more.

Blacky :smiley:

You don’t need to be informed exactly at the end. I mean it’s not like you are cooking something and the end has to be the end. Set a trigger level, start a timer. You know how long your cycle is.
Unit starts, power above a level for so long, start timer. Wait the amount of time that takes you into the last cycle. Watch for the off condition below some level for a certain time and fire the action you want.