Aqara air conditioning controller(advanced) cannot connnect


I am a freshman here.

use Pi, Raspbian, xiaomi gateway(gateway.v3) worked well on HA.

Recently I bought aqara air conditioning controller(advanced) . it can be used as a gateway. I can perfectly reach it through the MiHome app.


  • mac: 640980xxxxxx
    key: 8D6E7Fxxxxxxxxxx

but I got error, it is an unknown gateway.

2018-04-13 09:41:41 ERROR (Thread-22) [xiaomi_gateway] Unknown gateway ip

I searched on the forum. some friends suggested to use “custom_components”, I tried, but still error.

I am not sure if it is caused by version of LAN communication protocol. because aqara air conditioning controller(advanced) only support LAN communication protocol v2.0.

can anybody help me out ?



Could you share how u got it solved please ? I’m also searching for something like this. I use zwave remotec it climate component but its not reliable

I downloaded “custom_components” from below link:

and upgrade milo
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/homeassistant_venv/bin/activate
pip3 install --upgrade python-miio

then find these files( fan/,light/,switch/,vacuum/ ) under /srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/homeassistant/components
modify “python-miio==x.x.x” to “python-miio==0.3.3”

then restart HA.

Did u take a look at this

This is a community member custom component …I’ll try this

thanks, I tried , and it works well to control air conditioner. but the sub-devices cannot be found automatically.

so I want to connect air conditioning controller as a gateway.

What u mean with sub devices? Attributes ?

sub-device means mention sensor, wireless switch… except gateway devices

gateway mode not supported yet… we need update for acpartner device to support this

1 Like