Aqara Camera Hub G3 not found

Happy New Year everyone!

I got a brand new Aqara Camera Hub G3 and the core “Xiaomi Gateway (Aqara)” integration can’t find it. Neither with “any” in “Network interface to use” nor with the IP address of my Raspberry Pi 4 running HA, nor with the IP address of the G3 Camera Hub entered in the “IP address (optional)” field, nor with all three fields filled out, including the MAC address of the G3 hub.
I always get the red “Invalid hostname or IP address” error message from the integration setup.

In the HA log I get these error messages:

Logger: xiaomi_gateway
Source: /usr/local/lib/python3.10/site-packages/xiaomi_gateway/ 
First occurred: 12:55:18 (2 occurrences) 
Last logged: 13:04:39

No data in response from hub None


Logger: xiaomi_gateway
Source: /usr/local/lib/python3.10/site-packages/xiaomi_gateway/ 
First occurred: 12:55:18 (12 occurrences) 
Last logged: 13:05:29

Cannot connect to gateway 54........41

(MAC address redacted)

The firmware version of my G3 Hub is the latest available as of today, 3.4.8_0003.0004.

I read somewhere else here in the community forum that the hub might be discoverable only a short time after powering up so I tried to add the device via the above mentioned integration directly after a cold reboot – to no avail.

I can’t find any issues on GitHub for this integration related to “G3”.

The official documentation of this integration doesn’t talk about the G3 Hub, maybe because it’s rather new?

Also, this G3 Camera Hub can’t be added to the Mi Home App (yet). So there seems to be no way to follow the troubleshooting tips in the official integration documentation. :frowning:

So I give up. The G3 Aqara Hub doesn’t seem to be supported from the core integration, right?

There is a HACS integration that claims to be working for the G3 hub but I have yet to test it.

I had similar symptoms to what you described. Now my G3 and all of it’s connected devices are added to home assistant, but I can’t tell you exactly what fixed the problem, but hopefully there will be something useful in my description below for you.

First of all I want to clarify a few things that were confusing me after reading other people’s posts. From what I understand in HASS you have a couple of different integrations:

  • HomeKit: This will connect from HASS to an existing HomeKit proper controller (such as an Apple TV or HomePod)
  • HomeKit Controller: If you do not have/want to run HomeKit proper, you can alternatively use this integration to setup HASS to act as a controller.

As of right now, I am no longer running Apple HomeKit proper. HomeKit had become a confusing mess of duplicate devices and rooms and was causing me so many headaches with no benefits that I deleted my home. I suspect this was the thing that made integration between HASS and the Aqara G3 work, because it autodetected the isolated HomeKit devices and prompted me to setup a HomeKit Controller integration.

Also, my Netatmo weather station was also automatically detected after it became an orphan from my old HomeKit installation.

A secondary issue with my G3 possibly may have been that I was running it on a different network to HASS. Now they are both running on the same network which is not how I prefer, but I was fault finding why my G3 video feed would not appear on HomeKit proper, but now that I’ve deleted HomeKit I will probably try to move the G3 back to my IoT network.

I haven’t tried to do much else than get the G3 video feed working on a HASS dashboard but so far I’m sorry to say that trying to view the live feed through a Picture Entity Card seems to regularly break the feed including for the Aqara mobile app! The only way I’ve found to get it working again is to restart the G3 camera. :frowning:

I am having the same problem and hope to hear how you resolved it. I tried using the HomeKit no controller option and it did work but my camera keeps becoming unavailable.

I had hoped by adding the Aqara it would make my Magic Cube and TVOC sensor work more reliably. The last two alone don’t pair well with ZHA but older basic Aqara stuff seems fine.

I emailed Aqara customer support over my TVOC connectivity reliability issues and they sent me a replacement. So far it is performing much better than the old device, so don’t discount the possibility that your particular device is the issue!

Has anyone find a solution to connect the aqara g3 to HA ?

New flow for Aqara Hug G3, easy to configure and with more functions

FYI, I was having problems getting the g3 added to homekit in home assistant. It would show as a configurable device in homekit but when I pressed configure, it would just get stuck at loading the configuration wizard.

I think the problem is, you have to try to configure the camera “very soon” after it starts up. So try unplugging, wait for the camera to show in homekit in home assistant and then press configure and the wizard should load for you to enter the pairing code.

If you wait too long, you never get past the wizard startup to enter the pairing code.

1 Like