Aqara door/window sensors stuck in "on" state

For the past few weeks/months I’ve been experiencing some some of my aquara door/window sensors not correctly displaying the current state or updating.
I played around with the sensor a bit jerking it off with a secondary magnet while the door was open, which seems to have helped a bit, but it seems as if the relay can get stuck open/closed…
Did anyone else notice similar behaviour?

Did you try replacing the battery? Never had this problem with my 15 door/window sensors.

No had I. All my Aqara appliances are working rocksolid.
Have you reset the units in question?

They have been working well here also, for around a year.
But on the other hand, I don’t check the state every time I open a door/window and these don’t really trigger any automations.
I should look at replaing the battery (reporting 88%) and/or try removing/adding it from the network.

The battery reporting for these devices is useless in my experience. Two of them had to be replaced, but were still showing 100%.

I also have sometimes that the state in HA is not the correct one. Opening and closing the door again always fixes it …

As a soft alternative to a reset you could try to refresh the units using service: deconz.device_refresh and see if they react .

I notice the same behaviour since about a week.
Last night door “closed” after 3.5 hours while it was only open for a few seconds.

Did you find the problem? How did you fix it?
I’m having the same problem right now…
Should I buy a new battery? According to HA is 91% thanks in advance

I changed the battery, but the issues seems to occur now and then.
This sensor does not have a role in any automations for me, so its not something I will immediately notice. But sometimes I log in and check the status and can notice it being stuck in “open” for some time after the door is closed. (longer than minutes, up to hour(s))
Unfortunately I did not put any big efforts into this issue (yet)

I also have the same issue…
replacing the battery does not solve it unfortunately.

I wonder if it’s the sensor reporting the wrong state or ZHA that does not update…

I’ve exactly the same issue …in only 1 of my Aqara door/windows sensor.
Since yesterday the state is always “open”…I’ve already tried to reset, re-configure, etc…does not help.

I also noticed that if I have the magnet close and move it away it fires the event but the sensor state does not change…
Any idea how to solve this?

Update1: jus t. few minutes after…So I just trigger the “diagnostic” (just press to identify) and maybe the state updated ? …Not sure but for now is working…I will keep this post updated in a few hours and in a. few days…

Update2: no…unfortunately now (10min after my previous update1) is always on “close” state…

Anyone ever found a solution here?
I am using a Conbee II and firmware/application is fully updated.
Aqare sensor is always “open”. In the Conbee II application you can see the state and it says open all the time. It even says it’s refreshing. The sensor is brand new and worked a few times in the beginning.

1 Like

same boat ! I have sensors that i cannot use, i see the status in Tuya app but it stays open in HA

I solved this problem. That’s works for me at least.
First of all i took the sensor from the door/windows and i removed the battery from it.
Then, i removed it form Zigbee2MQTT control panel(click on red bin next to your device and tick “force remove” too).
I suggest you to save the device name before remove it, because it’s the name used in Home Assistant too, beetter keep the same for avoid to modify everything there.
Now i put back battery on sensor and i pushed the button fo device association, for this part i suggest you to stay close you your antenna.
Zigbee2MQTT will add your device and you can can give it the name you saved befor (i tick “use in ho assistant” too).
After the procedure it’s work again.

Sorry for my bad english, i hope to help you

I have problems with the MCCGQ11LM model (Aqara MCCGQ11LM control via MQTT | Zigbee2MQTT) that keeps dropping connection because it does not work well with my Zigbee routers. The model MCCGQ12LM (Aqara MCCGQ12LM control via MQTT | Zigbee2MQTT) works great tho.