Aqara EU power plug not reporting energy (ar anything)

Basically as in topic.

Have tried including a new Aqara EU power plug but cannot get it to report any measurements.
Controling the actual switch works.

And if I understand previous forum posts it seems like people have it working.

Anyone else experiencing the same.

Tried including it through the ZigBee coordinator
It iterates out six different sensors, power, current,voltage in different ways.

But all of them report “unknown”

Any advice on how to start is appreciated.
Thanks in advance


You plug, which version is it. I have a number of them, all the old version using zigbee 1.2 and working perfectly.
There are some reports on the new Aqaba zigbee 3.0 devices, which need to be defined in ZHA. Try and look in the forum for Aqaba T1 devices. If your plug is a new version, that might be the problem.

There’s many different Aqara/Xiaomi plugs and not all have quirks or quirk fixes for all power metering.

ZHA Device Handlers “quirks” is needed when device don’t follow Zigbee Cluster Library specifications:

Search for your specific Zigbee ID here was there will probably already be an issue reported for it:

PS: Zigbee2MQTT equivalent to zha-device-handlers/zha-quirks is called zigbee-herdsman-converters:

These parse/translate/convert non-standard messages to ZCL R6 or R7 (ZCL6/ZCL7) specifications:

Thanks @khvej8 and @Hedda, sorry for going silent.
There seems to be some bug or version conflict.
When downgrading Home Assistant, we got it working