Aqara FP2 does not bind

I do have 2 aqara fp2 sensors. Both were connected to HAand worked well.
One of the two got stuck in a recent update and did not respond at all. The other one did the update well and is still working fine.

So I did reset (push reset button >10 seconds)
Now I cannot bind the sensor again to the app (iPhone and iPad tried) version 4.2.3.
Tried all kinds of things, but it does not bind no matter what I try.

I do have a wifi network with WPA/WPA2 security
Inclusion in homekit is working, the sensor shows up and is reacting on motion and light.

The sensor is visible and pingable in my network.

But when the binding starts, the clock is ticking from 60s to 0s and than tells that it could not be binded. And nothingh shows up in the aqara app.
tried to import in the aqara app from homekit, but also binding is not working.

Please has anyone any idea of how to get the sensor working again?

Miracles happen.
Yesterday I tried at least 20 time to bind the device with no result.
Yesterday evening I unpluged the device and this morning I pluged it in again.
For the rest I did not change anything.

After the second try this morning the binding at once succeded. No idea why, but I am glad!