Aqara FP2 - HomeKit Controller - No unpaired devices could be found

I have a Home Assistant 2023.4.6 running on docker on 192.168.0.90
I downloaded Aquara Home app on my android phone. I set up the FP2 sensor using Aqara Home app. I can see the sensor in the app. I can configure it and everything works fine.

Then I wanted to add it to HA. I selected Settings → Devices & Services → Add Integration → Apple → HomeKit Controller and I got “No unpaired devices could be found”.

HA (192.168.0.90) and FP2 (192.168.0.227) are in the same network. My android phone (192.168.0.10) is also in the same network.

I have zeroconfig: enabled in configuration.yaml

FP2 firmware 1.1.6:005.0025
I can ping 192.168.0.227 from HA docker image.
I tried to reboot FP2 but no luck. What could be the problem? I also have other devices in the network like google chromecast, wled, etc, and HA discovers them without a problem.

update:
I installed Service Browser on my android and I can see my chromecast, esphome, printers, etc except FP2. Should I see it?

I have the same issues. But, I added it to an old iPhone, to get it onto the WiFi network. I can see it in the Home app. I removed the sensor from the Home app, but HA won’t give me a notification about discovered device when I put the sensor in discover mode.

Today I tried different router in my network but no luck.
Moreover I got an update to 1.1.7_0002.0025

Version: 1.1.7_00022023-05-18
What's New:
1. Fix the issue of not reporting enter and leave reports when entrance and exits zone is set.
2. Remove the limit that when there are targets within one meter, do not create other targets.
3. Optimize the target judgment logic in high sensitivity zones and fix issues where the target cannot be permanently maintained.
4. After setting up the entrance and exits zone, optimize the target algorithm , fix the problem of targets being taken away within 1 meter near the entrance and exits zone.
5. Modify the sensitivity logic for the entire zone, fix issues with target waving not being triggered and children not being able to detect.
6. Add monitoring parameter setting thread to fix situations where parameters cannot be set.
7. Optimize calculation time to prevent abnormal device restarts.
6. Add monitoring parameter setting thread to fix situations where parameters cannot be set
7. Optimize calculation time to prevent abnormal device restarts

None of the fixes above solved my problem.
I think that FP2 now is not in pairing state (or sth like this) so HA can’t see it.
I must borrow an iphone and try with a homekit.

I started additional HA in docker but with host network mode.
Then I restarted the FP2 and it immediately appeared in integrations.

1 Like

I found the same thing. Just by pulling the power cord on the FP2 and plugging it in again, it showed up immediately.

2 Likes

Good for you. :+1:
Unfortunately I don’t know anything about docker.

I have just installed the FP2 in HA using android (pixel) and NO apple anything (other than HomeKit Controller integration). For me, the HomeKit Controller did not see the FP2, but a power cycle on the FP2 solved that. Then the HomeKit Controller magically appear without adding it. On ‘configure’ I had an issue of not knowing the pairing code. Took trial and error to find the XXXX XXXX code on the device and translating it to the XXX-XX-XXX code required for the pairing.
After that it is just a sensor in HA and relating the ‘Presence Sensor 1’ to the device, then ‘Presence Sensor 2’ to the zone 1, etc.
Just updated the sensor firmware, hoping it solves the ghosting, but seems like an amazing step forward in sensors. Great work AQARA!!!

This is what made mine show up. Thanks!

I’ve done some experiments with the FP2 in my context: Mixed 2.4/5 GHz Google Wifi (significant factor) and HA running in docker (possible factor). Basically, you may get the FP2 to configure in the mixed network, but it seems to be hit&miss (presumably when you happen to have a weak signal) - by pairing from a phone that is locked to 2.4 that procedure becomes stable and once it works you can also use the Aqara app from a 5 only device. However, I still never got HA to pick up the FP2. However, with a dedicated 2.4 Wifi it shows up instantly. Sadly I’ve not found any way to temporarily enforce 2.4 on Google Wifi, but luckily I have a separate AP that can do that. Hope this helps someone. :crossed_fingers:

I had a variation of the above. After tons of struggles to get it on my Unifi Wifi (an old phone I no longer use did the trick, none of the upper/lower case, special characters etc tips were of any help) my HA detected the FP2 however it would just not join HK (tried many times and with the correct code format). A reboot of the sensor did the trick. :man_shrugging: I thought I read that you needed to remove the sensor from the Aqara app but I did not which is great so it should be possible to update the firmware and configure the FP2 as needed while keeping it in HA. I have not done any of this yet… so I am not certain it all works leaving it like this.

Thank you. This worked for mine too!