Aqara Fp2 - Homekit device integration - Proxmox

Hi,

I just bought & configured an aqara fp2 presence sensor.
I added to my Android Aqara App and I can ping it with its own IP address.
It works fine.

I have my HA (2023.7) instance running con a VM inside Proxmox.
I have zeroconf enabled in HA.
But, for some reason HA does not auto discover the FP2.
I read the documentation HomeKit Device - Home Assistant and I did the check they suggest:

python3 -m netdisco

I get 0 devices discovered.
But I can ping the sensor from HA.

So, now I’m stuck and I don’t know what to do in order to get it discovered.

One more info. I have a second HA instance on a Raspberry pi 3. Here, fp2 is detected as “Homekit Device” but if I try to configure it gets stuck and it does not ask for the code.

What can I try to fix the problem of my main HA instance?

Thanks for any help I can get
Marco

I just started having issues with my FP2 not updating in HA meaning it wasn’t showing when occupancy happened. There would be a min or two delay. It happened when I updated to 2023.8.1 or I thought that was in. But I run proxmox as well and I think the same day I updated HA to 2023.8.1 I updated whatever updates there were for proxmox. I’m wondering if this is what is causing my issues. I just deleted the FP2 completely from HA and the aqara app. Set it back up with Aqara and my Apple TV. Created an automation and it works instantly. I deleted it from HomeKit and generally HA finds it as a new device to add to HA, but it will not see it at all.

But I will also add, it’s not showing up as being able to add it back in to HomeKit on my iPhone in the Home app either. So this leads me to believe it may be an issue with Aqara more than anything else.

Try power cycling the FP2. I just got mine to show up doing that.

Thank you for the suggestion, I will try out before return the sensor to Amazon.

HA relies on mDNS to discover Homekit devices which is what netdisco is looking for. Given that you aren’t seeing the sensor, then it either is not advertising via mDNS or mDNS is blocked between the sensor and HA. If they are on the same network, then I would look at the Proxmox network. If they are on different networks, I would start by seeing if you can find it via mDNS from a device that is local to the sensor and go from there.

Thanks for the explanation.
I have another HA instance in a Raspberry and it detects the FP2.
I have all devices and servers on the same network.
It looks like it is something to do with Proxmox but I don’t know what to check and/or change.

Thanks @fightingmajor this solved the problem.