Aqara Hub (M1S Gen 2)

Hi today I’ve got my new Aqara Hub M1S Gen 2. It is a replacement for my old Aqara Hub 1st version.

It was pretty easy to integrate,

  1. Removed old Hub from Aqara app
  2. Plugged new hub in the socket to wait for bootup
  3. Add to Aqara app
  4. Readd all 100 things with names and rooms…
  5. Restart home Assistant - wait till done
    (So far not recognized by HA, after 45 min in the network)
  6. Unplug hub wait 10 seconds and replug to power
  7. HA shows the hub as Home kit controller
  8. Add to HA with the provided code (on hub or box)

Everything works fine…, Oh I forget to say region is for me Europe in Aqara app.

It looks like that the hub only after bootup provides the info that it is a homekit controller.

Version Details:
Home Assistant 2022.11.2
Supervisor 2022.10.2
Aqara Hub: 3.4.6_0007.0004

Would be nice if someone else could review this process to confirm it works. I only found this funny description where you have to use the Xiaomi app and the Chinese server, click a version number x times, reset the hub and whatever else is described here.

This could result in a better description for the integration and troubleshooting section.

Kind regards


It worked with mine, also on EU region. Thanks for sharing the procedure.

1 Like

Step 7 doesn’t work here.
It is not shown on HA.

Yes, it works so easy and straight forward!

I just moved it to another room and when restarted then it appear automatically as Home kit controller integration. It is looking for the code sticker on top of the device 111-22-333 (sticker - 11122333)

Home Assistant 2022.12.8
Supervisor 2022.12.1
Operating System 9.4
Frontend 20221213.1 - latest
Aqara Hub: 3.4.8_0012.0020

still available in my Aqara app

1 Like

Thank you, I have the Aqara Gateway M1S Gen 2 and i could not integrate with the “Xiaomi (Aqara)” integration in HA, but your guide help me a lot because i think that focus on the main point: the integration is with “Apple Home kit controller”, not Xiaomi!.

But the critical point to find the device in the “Apple Home kit controller” HA integration manager is that the hub MUST NOT be already paired with an homekit hub (such an Apple TV or iPhone).
So (and it worked!) i tried to reset the Aqara Hub (because before i was connected with the iOS app), then connect again but with an Android phone (Aqara app from Play Store).
Android doesn’t automatically create a Homekit integration (of course!) so the hub will connect to the Xiaomi cloud and the wireless network, THEN you can find and add the hub in the HA “Homekit controller”.

TLDR: Your guide works for me, but it’s crucial that you have to connect the Hub in the Aqara app with an android phone and not iOS.

1 Like

You should try to reset the Hub then to connect again BUT NOT with an Apple device. You can try the Aqara app on Android. Do not add the Hub to Apple Homekit. You can do that by Home Assistant integration (step 7).
Let me know if it helps.

I only use Android devices so I never recognize this problem thank you for the additional information.

Integrate Aqara Hub M1S gen2 to home assistant in Aqara app Europe server + homekit controller

Is anyone using mainland China and can you add ?

The Aqara home app allows you to add the Aqara hub, but in order to get the complete
experience from the hub, you should use the server relevant to the region your hub belongs to.

So, if you have a Chinese hub, the hub will work as intended when signed into the Aqara home app, with the server set to ‘Chinese’.

If you have the US or European hub, then the US or EU servers are the best ones to use.

Guide for see post from app and replace into HA

Aqara Hub M1S Gen 2 Europe version and Europe server in aqara home app?

Integration to HA worked, but can I use the hub for something other than night light, alarm or router for Aqara sensors? Can I use the speaker for something? Can I use it as doorbell for example?

New flow for Aqara Hug G3, easy to configure and with more functions

I confirm that you must use android instead of iPhone!!! Thousand thanks for the countless hours that I would have spend!! :sweat: I have restart a new home assistant setup, but I have use an android in the previous one. I have now an iPhone… and still my old android. :sweat_smile:

I would also suggest to turn off your iPhone during the operation of integration as it didn’t work the first time. I turned of my iPhone of the second time and it finally worked as expected.

Was playing around with this and have an update for ios users.

Here are the steps I followed for M1S hub:

  1. Factory reset
  2. Using code, add hub to Apple Home
  3. In aqara app, bind newly added hub. Profile->Homekit->Homekit devices and bind the hub.
  4. In Apple Home, delete hub
  5. Fairly quickly, open home assistant and bind using the Homekit device integration and the HK code on the device. I think there’s a few minutes of leeway on this but I think if too much time passes, aqara app might get upset.
  6. The hub, along with any devices added to it, will show up automatically but remain available in Aqara app as well.
  7. ONLY add additional devices using the aqara app. They will populate along with the hub in homeassistant automatically.
  8. As an added bonus, from here you can add back to Apple Home using the Matter code generated in the app. :grin:

Hope this helps. Happy to expand on any steps if needed.

1 Like

This worked for me! Finally got the M1S hub in my HA. Didn’t follow your guide exactly, it got me to the right spot.

(Mine is not present in the Aqara app tho)

I think I did something like this:

  • Remove hub from Aqara
  • Remove hub from Home Kit
  • Walking around trying to figure out wtf is happening
  • Check my router to see if the hub is still on the wifi - YES it was
  • Noticing a new device popping up in HA!
  • Add it - and got the sensors with it
  • :tada:
1 Like