Aqara Lumi light sensor power as mains instead of battery?

I have tried pairing it twice and reconfigure device but for some reason it still says the power is on mains instead of battery

It will probably need a “quirk” (ZHA Device Handler) if manufacturer has configured firmware wrongly:

Report a new issue as a “Device support request” to the ZHA Device Handlers repo if none exist yet:

Note that it is important that post Zigbee Device Signature ID and also use as topic identifier for clearity:

As mentioned in ZHA exception and deviation handling section, the reason for this type of issues almost always that the manufacturer has not followed the official Zigbee Cluster Library specifications when configuring the attributes it the firmware.

ZHA can usually be worked around by using custom “quirks”, but the best solution should really be for the manufacturer to correct the configuration via a firmware upgrade,

If possible you should also always try to report these types of problems to the manufacturer as well.

1 Like

what sensor is that? could you share a picture?

Aqara Light Detection Sensor T1 (GZCGQ11LM) Zigbee compatibility this is the sensor I’m using

1 Like

I have two of them working with a conbee II and ZHA without flaws… Not sure this info helps but, just in case.

1 Like

For me it works too, but the only thing is power is read as mains for some reason instead of battery, maybe I should try re pair it a few more times to see if it changes.

Using a Tubes ZB CC2652P2 ethernet cordinator with zha

Apparently it might just be an issue on my side as another comment mentions it working for them, but if it fails I would report a new issue, thanks for sharing and helping out :slight_smile:

Also be sure to upgrade to latest firmware →

1 Like

looks like i also have to update to the latest firmware, thanks for sharing the link

Have updated my coordinator to the latest firmware and also repaired the light sensor but it still shows up as mains instead of battery

Then it will need a custom quirk →

1 Like