Aqara motion sensor won' t particpate in zigbee network

After getting an Aqara Cube, I migrated my zigbee from Deconz and Conbee to ZHA with Sonoff dongle-E. A bit of work, but the Cube did not do what I wanted with Deconz.
After migrating I had issues with the Aqara motion detectors. I went through lots of posts here and elsewhere, but I cannot get the motion detectors working. They connect alright and will keep working for a couple of hours, and then they become unavailable. Resetting, new batteries, longer time to keep alive. They will come back alive, and disappear again. I removed zigbee routers, tried again etc.
What I noticed is that after the paring the motion connectors will be graphically represented without a link to a zigbee router or the coordinator.
For testing purposes, I used an unused spare. Same result. The other aqara sensors, and the zigbee switches all work like a charm. I can of course bring back Deconz and Conbee, but that feels like losing (even worse as admitting that I cannot solve it and need to ask for help).

I am running into the same issue. Did you ever figure this out?