Aqara temp/humidity sensor no longer updating some sensors

i’ve recently discovered that both of my aqara temp/humidity sensors have stopped sending updates reliably and isnt (/doesnt) appear related to any changes.

pictures are worth a thousand words:

last reliable update was at 1:26:51 AM so this is far outside of any changes or maintenance which i’d typically do on a weekend morning.
Temperature is still being updated as expected, but all other entities from these sensors stopped at this time.

Batteries have been changed, and pressing the ‘update now’ button on the side of the sensor has no effect on the entity value.

if it was one sensor, i’d go with hardware fault but since they both failed at the same time, then appears to be HA side.

the fact that temp seems to be updated implies that zigbee is working ok so i havent gone with repairing . I’m currently using ZHA but will migrate to Z2M once my 2nd zigbee POE co-ordinator arrives over the next few weeks, so i can migrate these problem sensors first to see if it fixes them.

any ideas on how to fix this one?

I have exactly the same issue…temperature is updating but not the humidity.
Maybe in a damp environment, like a bathroom in my case, the humidity sensor itself fails. Mines stuck on 71%.
I haven’t tried pairing it back up with HA…so that might be worth a go for you.
Be interested to see how you get on.

the one i’ve screenshot’d is in the bathroom (using it as part of a baysian sensor for extractor fan control). the other sensor is in the conservatory for ceiling fan auto-control.

I’ve gone for a battery-pull for a few hours as a ‘soft reset’. See if it work before a full re-pairing.

Same here again…using the humidity sensor to control an extractor fan.
I’ve dropped one of these in the bathroom to replace the Aqara one:

Good luck with the fix.

fixed it!

replaced my sonoff USB dongle with the smlight PoE zigbee coordinator last night and it appears to have fixed the issue.

i suspect it was a pairing/network issue rather than the dongle at fault so going through the ‘migrate radio’ of ZHA has changed something to correct it.