Aqara TVOC air quality monitor

Does anyone have experience integrating the Aqara TVOC sensor into HA? I can integrate it with ZHA and it shows 2 entities: temp and humidity but unfortunately nothing else. Is there a way to manually surface the TVOC entity. Thanks for your help!

3 Likes

Also interested in this!

Yes This would be great… I have this sensor and I’d like to integrate!

Same here. Just installed and sad to see that the air quality is not showing

I’m also seeing the same behavior. Unfortunately I bought it specifically to monitor VOCs, so hoping somebody has knowledge to share on this.

Hi. I integrated the aqara Air Quality Monitor in ZHA and indeed only the temp and humidity are detected.

What I now experience is that they sensor updates only after 2-3 hours. Anyone alsof having this problem?

Also the percentage is different on the device than in ZHA… Weird!

I added the Aqara TVOC to my system and have only had issues with it dropping off the Zigbee network. It also updates very seldomly. This is unfortunate as I am trying to find a humidity / temperature sensor I can standardize on and have around the house but my initial testing does not bode well.

Other than TVOC not showing up in HA, are any of you having issues with connectivity? Since this one said it was Zigbee 3.0 I did not think it suffered from the connectivity issues that all the other non standard Zigbee Aqara sensors appear to have.

In case it matters, I added this device via a Jasco zigbee in-wall outlet in the same room so signal should never be an issue.

VOC is now available through ZHA. In units µg/m³. And update frequency is much more often. Great!!

4 Likes

I am regretting the purchase… it keeps dropping off my Zigbee mesh network (~90 devices with wired ones up close to the air monitor) and to get it added back I have to remove it and re-add. Also, it appears to be reporting humidity once every “fill in super long delay”. I have multiple sensors all in the same spot for comparison and the Aqara sensor reads the highest humidity of all, so I tend not to believe it as it does not match anything else I have. It exceeds the other readings by more than 5% most of the time. The only good thing is that the temperature matches all of my other sensors but that too does not update as often. My other sensors are DHT22 x 1, 18B20 x 2, HTU21D x 2 (one running at a time), and an AcuRite standalone sensor. None are super accurate but they all jive. My sample size for humidity is smaller but they tend to jive too except for the Aqara.

Most importantly, this thing is useless if it doesn’t update humidity more often (I was hoping to have automations run based on it… ie: fan during shower) and if it keeps dropping off the network.

EDIT: It chewed up the 2 new batteries I replaced in a matter of a 2 weeks or so. Either I am unlucky, or this sensor is trash.

Hi, Did you find a way to match AQ levels based on µg/m³?

Just added one of these to my home and it has been reporting data to HA consistently for days (connected to a Conbee II and ZHA integration).

Only issue I’m seeing is that the air quality unit of measurement is wrong and scaled incorrectly. For example, when mine reports 75000000 µg/m³ in its HA state, the device itself shows 75 ppb (double tap the button on the top of the device to change between screens).


This Chemistry StackExchange post explains the conversion between these units and also mentions that “Note that all notations involving “part per something” are deprecated and should be avoided”

It seems that in HA the unit should be changed and scaled down to align with what the device reports. I’m not sure where the proper place to report this would be.


As for interpreting the levels, I’m not sure what numeric values correspond to the leaf icons displayed on the device’s main screen, but this Airthings post indicates that <250 is “low”, and anything above that could be cause for investigation.


I’ll also note that I’m displaying this data in my dashboard using mini-graph-card and the following config.

type: custom:mini-graph-card
name: Kitchen Air Quality
entities:
  - sensor.kitchen_air_voc
show:
  icon: false
points_per_hour: 2
value_factor: -6
unit: ppb
color_thresholds:
  - value: 500000000
    color: '#ff0000'
  - value: 250000000
    color: '#ffa500'
  - value: 0
    color: '#00ff00'

3 Likes

great post (from guessing a fellow Canadian - judging by your picture and name haha), with links, pics and info - much appreciated.
To confirm for others also - paired up just fine for me (no connection issues at all -running two weeks) and shows all 3 entities (just with the noted TVOC reading scale outta whack). Got er $12 CAD off so I’m a happy camper with this purchase.
Cheers!

1 Like

BTW the TVOC scale has been fixed in the development version on Github, so should come down through a stable version update in the near-ish future.

2 Likes

Beautiful, thanks for that - looking forward to it! - I saw a few ZHA updates coming in the 2021.12 :star_struck:

hello everyone!

I just bought and connected this Aqara device today.
I can see the entities for humidity, temperature and TVOC.
But values are not updating.
do I have to do anything to make it update more frequently?
FYI, I’m running the latest version of HA OS, everything at the latest version. Conbee2 and ZHA

/edit
humidity is updating often.
but temperature will only update after a reboot of home assistant.
and tvoc is not updating at all.

2 Likes

Thinking of getting and using with Conner ZHA. Will I be able to switch the display to Fahrenheit without Aqara app?

1 Like

I am also wondering this. I don’t see any configuration options for the device.

I am also very interested in using this device but the above reports and the Amazon reviews are not very promising. Anyone have an actual good experience to share with a working setup?

I’m using this sensor with Deconz for ~7 months now. Basically it works, though have tendency to stop updating HA with changed values once in a while (once evry two weeks?). Sensor show updated values on the screen, but does not send this to HA. Short press of the button on top instantly resolves this issue. Might be annoing in winter, as I use it as external sensor to TRV.
Using plane installation it is not possible to change C to F. You can reconfigure this in HA itself, but this will change unit of measure (and will recaltulate value) that HA uses internally, not what is displayed on the screen.

One thing I noticed is that when reconfiguring the device, I get an error that the XiaomiAqaraE1Cluster did not configure properly, and the process fails. Perhaps if this worked there would be some configuration to change the temperature units? Any ideas for how to make this complete successfully? I have tried many times and always get the same result.

DEBUG (MainThread) [homeassistant.components.zha.core.channels.base] [0x0A82:1:0xfcc0]: Failed to bind 'manufacturer_specific' cluster